UT Linux sound too fast

Archived from groups: alt.games.unreal.tournament (More info?)

Hello!

ATI Linux drivers have issues with UT2004, so I thought I'd retro, dug
up my old UT CD, got a Linux installer, and installed the game. Besides
the obvious realization that my machine is overkill for this game, I
also noticed that the sound plays too fast. Quite literally! Everything
sounds like it's being fast-forwarded (remember cassette tapes?).

I'm on Debian with ALSA sound, kernel 2.6.3.

Any ideas?
9 answers Last reply
More about linux sound fast
  1. Archived from groups: alt.games.unreal.tournament (More info?)

    Artom enlightened us with:
    > ATI Linux drivers have issues with UT2004, so I thought I'd retro, dug
    > up my old UT CD, got a Linux installer, and installed the game.

    Which version of the game do you have?

    MeltDown
    --
    !For all your UT99/2k3/2k4 questions visit UnrealTower's FAQ section:
    ! http://www.unrealtower.org/faq
    !Home of the FAQs for agut and agut2003.
  2. Archived from groups: alt.games.unreal.tournament (More info?)

    436.
  3. Archived from groups: alt.games.unreal.tournament (More info?)

    Might as well add that it's a NForce2 mobo with an Intel 810 onboard
    sound chip.
  4. Archived from groups: alt.games.unreal.tournament (More info?)

    Artom enlightened us with:
    > Might as well add that it's a NForce2 mobo with an Intel 810 onboard
    > sound chip.

    Ah, yes. I've had problems with that too on a friend's computer. Don't
    know what fixed it, or if it was fixed at all. Try playing around with
    ALSA, ~/.asoundrc and ~/.openalrc.

    Version 436 is right, though ;-)

    MeltDown
    --
    !For all your UT99/2k3/2k4 questions visit UnrealTower's FAQ section:
    ! http://www.unrealtower.org/faq
    !Home of the FAQs for agut and agut2003.
  5. Archived from groups: alt.games.unreal.tournament (More info?)

    Mind putting me in touch with that friend? :)

    I don't wanto turn this into a Linux discussion, but I have neither a
    ..asoundrc or a .openalrc. Don't think I'm supposed to either, the Debian
    website doesn't show any packages with those files in them.
  6. Archived from groups: alt.games.unreal.tournament (More info?)

    Artom wrote:

    > ATI Linux drivers have issues with UT2004, so I thought I'd retro, dug
    > up my old UT CD, got a Linux installer, and installed the game. Besides
    > the obvious realization that my machine is overkill for this game, I
    > also noticed that the sound plays too fast. Quite literally! Everything
    > sounds like it's being fast-forwarded (remember cassette tapes?).
    > I'm on Debian with ALSA sound, kernel 2.6.3.

    I had exactly the same problem. Couldn't find a fix for it, but you do
    kinda get used to it. I found it helps to think of the Announcer as
    being on Acid.

    --
    Flash
  7. Archived from groups: alt.games.unreal.tournament (More info?)

    Artom enlightened us with:
    > Mind putting me in touch with that friend? :)

    He doesn't know anything about Linux - the OS is on his box because I
    visit him often ;-)

    > I don't wanto turn this into a Linux discussion, but I have neither
    > a .asoundrc or a .openalrc. Don't think I'm supposed to either, the
    > Debian website doesn't show any packages with those files in them.

    That's right, you're supposed to make them yourself. My .asoundrc is
    empty, and my .openalrc contains:

    (define speaker-num 4)
    (define devices '(alsa))
    (define alsa-out-device "surround40:0,0")

    MeltDown
    --
    !For all your UT99/2k3/2k4 questions visit UnrealTower's FAQ section:
    ! http://www.unrealtower.org/faq
    !Home of the FAQs for agut and agut2003.
  8. Archived from groups: alt.games.unreal.tournament (More info?)

    I've been using the same sound card with the OSS drivers and works great.

    I have Debian Testing w/Kernel 2.4.25 with Low Latency Option.

    If you use ALSA, check the sample rate, that would make the sound play too
    fast. Alsa also permits sample rate locking, so the audio portion of the
    game could be playing at a reduced sample rate which gets reinterpreted by
    ALSA to 44.1 or 48k.

    ..-=/gp\=-.

    "Artom" <artom@sympatico.ca> wrote in message
    news:997ed.32172$J16.1809064@news20.bellglobal.com...
    > Hello!
    >
    > ATI Linux drivers have issues with UT2004, so I thought I'd retro, dug
    > up my old UT CD, got a Linux installer, and installed the game. Besides
    > the obvious realization that my machine is overkill for this game, I
    > also noticed that the sound plays too fast. Quite literally! Everything
    > sounds like it's being fast-forwarded (remember cassette tapes?).
    >
    > I'm on Debian with ALSA sound, kernel 2.6.3.
    >
    > Any ideas?
  9. Archived from groups: alt.games.unreal.tournament (More info?)

    In article <997ed.32172$J16.1809064@news20.bellglobal.com>, Artom wrote:
    > Hello!
    >
    > ATI Linux drivers have issues with UT2004, so I thought I'd retro, dug
    > up my old UT CD, got a Linux installer, and installed the game. Besides
    > the obvious realization that my machine is overkill for this game, I
    > also noticed that the sound plays too fast. Quite literally! Everything
    > sounds like it's being fast-forwarded (remember cassette tapes?).
    >
    > I'm on Debian with ALSA sound, kernel 2.6.3.
    >
    > Any ideas?

    Van de Childsplay mailinglist:

    Hello,

    A known issue with the playing of sound in applications that use
    SDL/pygame is that, in conjuction with ALSA and some soundcards,
    the music/sound plays to fast.
    At least the one that are not in 44100 Hrz.

    A proper solution is to have a .asoundrc file with a software mixer
    which resamples the sounds to 44100 (at least on a via82xxx).

    (A example .asoundrc file is included at the end.)
    This file should be placed in the users home directory or it can be
    used globally when placed in /etc/asound.conf.

    To force SDL to use the ALSA drivers/libs one has set a env variable
    like this: export SDL_AUDIODRIVER=alsa
    This can be placed in the users .basrc script or so.

    When the application is started all the sound are resampled to 44100
    and sounds normal :-)

    #v+
    pcm.!default {
    type plug
    slave.pcm "dmixer"
    }
    #v-

    GG
    Kees
    --
    Visit me at http://www.xs4all.nl/~kostercd/
    Orcs really aren't so bad (if you use lots of catsup).
    09:03:42 up 1 day, 21:01, 4 users, load average: 0.29, 0.26, 0.15
    Linux Registered User #300181 | ICQ #179658498 -- # EOE
Ask a new question

Read More

Games Linux Video Games