Sign in with
Sign up | Sign in
Your question
Solved

R5770 Directx 10 problem

Last response: in Graphics & Displays
Share
Anonymous
July 7, 2010 6:47:51 AM

I just bought an MSI R5770 Hawk and its awesome, except for one thing...
I ran some benchmarks for Farcry 2 with everything maxed and its saying im getting an average FPS above 40 (20 fps min) but when i run with directx 10, the screen appears choppy and looks like im getting low FPS even tho it may display 40fps on benchmark. I dont have this issue when i put it on directx 9, just directx 10.

Is it a driver issue? What do i do? :??: 

More about : r5770 directx problem

July 7, 2010 7:18:38 AM

Does enabling DX10 change the Vsync setting?
m
0
l
Anonymous
July 7, 2010 7:56:06 AM

no, everything is the same, just directx difference
m
0
l
Related resources
Anonymous
July 7, 2010 8:21:21 AM

bump
m
0
l
July 7, 2010 11:43:41 AM

Does it happen in other games, or just Frycry 2?

DX10 will drop the frame rates in games, so its possible that your 40FPS (dropping as low as the 20s) is going even lower in DX10. If so, it will appear to be choppy as you play/benchmark. Try lowering the settings. If it is a DX10 issue it should continue to happen.
m
0
l
July 7, 2010 12:17:22 PM

Quote:
I just bought an MSI R5770 Hawk and its awesome, except for one thing...
I ran some benchmarks for Farcry 2 with everything maxed and its saying im getting an average FPS above 40 (20 fps min) but when i run with directx 10, the screen appears choppy and looks like im getting low FPS even tho it may display 40fps on benchmark. I dont have this issue when i put it on directx 9, just directx 10.

Is it a driver issue? What do i do? :??: 


what PSU u are using for MSI R 5770.
m
0
l
July 7, 2010 6:07:01 PM

I had this problem initially as well, you need to play with the V-Sync settings. I can't remember if it needs to be enabled/disabled, but it shouldn't take too long to adjust those settings. If that doesn't work lower the texture quality. Even on my 5770 with 1GB of RAM it was causing issues.
m
0
l
Anonymous
July 7, 2010 8:31:06 PM

jpe30 said:
I had this problem initially as well, you need to play with the V-Sync settings. I can't remember if it needs to be enabled/disabled, but it shouldn't take too long to adjust those settings. If that doesn't work lower the texture quality. Even on my 5770 with 1GB of RAM it was causing issues.

i will play with texture settings, but y directx 10????

m
0
l
Anonymous
July 7, 2010 8:51:44 PM

I played with all of the settings, turned them down but with directx 10 still on, and its still very choppy. If i turn settings to max on directx 9, no problem. Driver issue?
m
0
l
July 8, 2010 12:22:17 AM

Quote:
DX10 will drop the frame rates in games, so its possible that your 40FPS (dropping as low as the 20s) is going even lower in DX10. If so, it will appear to be choppy as you play/benchmark. Try lowering the settings. If it is a DX10 issue it should continue to happen.


DX10 = lower frame rates then DX9. And its not a driver issue. We still don't know the rest of your system specs. For all we know its you 1GB of ram...
m
0
l
Anonymous
July 8, 2010 12:45:04 AM

4745454b said:
Quote:
DX10 will drop the frame rates in games, so its possible that your 40FPS (dropping as low as the 20s) is going even lower in DX10. If so, it will appear to be choppy as you play/benchmark. Try lowering the settings. If it is a DX10 issue it should continue to happen.


DX10 = lower frame rates then DX9. And its not a driver issue. We still don't know the rest of your system specs. For all we know its you 1GB of ram...


AMD PhenomII 955 x4 @3.2ghz, 8gigs ddr3 ram, 1.5TB HD, 650watt PSU

anything else?

btw- when running on DX 10, the screen appears choppy but it says the framerate is 35+, no problem with DX 9
m
0
l

Best solution

July 8, 2010 1:35:23 AM

Doh, I remember my solution now!

Set V-Sync to off (this is required for the following, but also will cause a significant amount of input lag under DX10), and set the max_fps:

- Press "~" to pull down the console.
- Type "gfx_maxfps **" - where ** is slightly higher than your average framerate. So in this case you might want to try "gfx_maxfps 50".

For whatever reason this removed the stuttering for me, hopefully it will also work for you.

Enjoy!
Share
Anonymous
July 8, 2010 2:40:38 AM

Best answer selected by killwizz.
m
0
l
Anonymous
July 8, 2010 2:42:16 AM

WOW THANKS! I CANT BELIEVE THAT ACTULLY WORKED!
I would have never thought it was actully a problem with the game itself.

Thanks a bunch man! You made someone happy today. :D 
m
0
l
July 8, 2010 3:46:00 AM

No prob! Glad to hear it worked! :) 
m
0
l
!