Sign in with
Sign up | Sign in
Your question

??? Memory stable in Linux but not Win7_x64???

Last response: in Memory
Share
June 17, 2011 2:45:27 PM

Okay, this is just weird.

I upgraded my ram from two 2gb sticks of OCZ Platinum DDR2-1066 (4gb total) by adding two more 2gb sticks of matching OCZ Platinum DDR2-1066 memory. Result? Windows 7 (64bit) gives me a BSoD roughly every 20 minutes.

I first kept the BIOS "Auto" settings, but after the first crash, I boosted the DRAM voltage to 2.2v (from 1.8v) and boosted the timings to match the memory (5-5-5-15). When that crashed, I reverted the timings in the BIOS back to AUTO but left the voltage at 2.2v (which CPU-Z and every source I've found says is necessary.)

When *that* crashed, I booted Ubuntu Linux 11.04 (32bit) and have been running stable for over an hour.

So, clearly, the fault lies with Windows 7, not my BIOS or the memory.

A permanent switch to Linux just isn't an option. Anyone have any idea what is needed to fix this?

----------------------
Gigabyte MA790GP motherboard with the latest BIOS upgrade.
Four sticks of 2gb OCZ Platinum DDR2-1066 memory.
AMD Phenom-II X4-920 processor.
ATI Radeon 5850 video.
750watt p/s.
a b } Memory
June 17, 2011 3:01:19 PM

Are you sure it's the memory? You can test the integrity of the sticks by running memtest86. This needs to run overnight.

You are running the memory at 1066 MHz (data rate), right?

It depends on what you mean by "fault". :)  I think Win7 is probably just harder on memory or something. Did you somehow stress your system while running Linux?

If you think Windows is the culprit, you can try a fresh in stall (preferably on a spare HDD).

You can try either slowing down the RAM or relaxing the timings to 6-6-6-whatever.
m
0
l
June 17, 2011 3:07:37 PM

eightdrunkengods said:
Are you sure it's the memory?
Thanks for the reply.

Actually at this point, I don't think it is a hardware issue at all. Same hardware, same settings. Win7 crashes. Linux just fine.

Both fairly clean recent installs. Both ran rock solid with only 4gb of memory for two years, but after adding the extra two DIMMs this morning, only Linux is still stable.

I will try one more test. I also still have Win XP installed on another partition. I will try it later (when I get a moment) and see what happens.

UPDATE: Is there any greater enemy of the hacker than "Coincidence"?

Upon reboot from Linux, BIOS hung at the "Detecting IDE Devices" stage. This got me thinking: "My Linux is on a separate physical drive than Win7" (Linux on USB pen drive. Win7 on SATA. Old IDE drive only for data). I wondered if I bumped a cable while installing my memory? So I reopened the computer, tried reseating my IDE cable next to the DIMM sockets (though it was not loose) and rebooted the computer. It didn't hang this time, but I booted XP anyway to see what happens. XP also ran solid till I decided to reboot about an hour later.

Suspecting that reseating the cable may have "fixed" the problem, I booted back into Win7, which promptly crashed again (BSOD) five minutes later.

Upon rebooting, I noticed that BIOS was no longer detecting my sole IDE drive. I'm going to try disconnecting it later to see if maybe it's dying, causing the problem. But why would it affect Win7 and not XP?

I've tested 32bit Linux and 32bit XP... both of which can't access the extra 4GB of memory. So I will also try running 64bit Linux to see what happens (yes, I have *four* OS's installed just for things like this.)
m
0
l
Related resources
June 17, 2011 8:11:23 PM

eightdrunkengods said:
You can try either slowing down the RAM or relaxing the timings to 6-6-6-whatever.
Okay, here's where things stand:

64bit Linux (also on an external drive) ran fine and stable. After about an hour, I rebooted and ran "Memcheck86" (on the Linux boot menu.) It reported errors in the upper memory blocks above 4GB (the new ram). But I've seen this before. It doesn't necessarily mean the ram is bad. Back to BIOS, I set all DRAM settings to their defaults and "underclocked" the memory to DDR-800, then rebooted and ran MemTest again. No errors. (CPU-Z identifies the memory correctly as OCZ P1066, and it has the distinctive "Z" heatsink/grill, so I'm confident it's not counterfeit.)

I rebooted and suddenly noticed my sole IDE drive was no longer being detected during the "Drive Check" at boot. So I opened the computer, unplugged the cable at the MoBo, and rebooted.

No boot. "NTLDR missing". Apparently, Win7 installed the boot loader to the IDE drive. After three attempts to "Repair" my installation using the Win7 install DVD, NTLDR was finally fixed and Win7 was loading again.

No IDE drive and memory "underclocked" to 800, and everything seems to be stable again.

I don't think the IDE drive is bad. I think the bootsector may simply of been corrupted in one of the sudden BSOD reboots.

Now, the $64 question: My can't I run all my memory at 1066?


m
0
l
a b } Memory
June 17, 2011 8:25:45 PM

Memtest86+ is the most reliable way to make sure your memory doesn't have errors. I typically run it overnight since this allows it to run three or four times (the program will restart when it finishes). If RAM clears 4 runs of Memtest86+, it's almost certainly fine. If I were you, I would run this tonight to rule out a problem with your RAM - especially since your RAM gave an error on the Linux-based memcheck thing.

Just to be clear: Windows 7 is the only environment in which your RAM isn't stable @1066 (ignoring the errors form Memcheck), right?

Other easy things to try:

Set your RAM voltage to "Default" or "auto"

Clear your CMOS (another poster just had some luck with this... I think). Couldn't hurt.

m
0
l
June 17, 2011 9:38:30 PM

eightdrunkengods said:
Just to be clear: Windows 7 is the only environment in which your RAM isn't stable @1066 (ignoring the errors form Memcheck), right?
Yes... though keep in mind two things:

The Linux I first used was only the 32bit version of Ubuntu 11.04, so it didn't even see the extra ram. Ditto for XP.

The 64bit version of Ubuntu 11.04 likewise ran just fine, but it may have never tried to access the extended memory (Linux doesn't use "pagefiles" like Windows does.)

So whether it's a memory problem or not, I still can't say.

Before I bought my matching OCZ memory (identical to the two 2GB sticks of OCZ DDR2-1066 I already had), I tried two sticks of Kingston DDR2-1066. When I tried running my system at 1066, I had nearly the same problem. Only clocking the ram down to DDR2-800 made my system stable again. "Gigabyte" told me I had to use "matching" memory to run at 1066. So I returned the Kingston and bought the matching OCZ, only to find I'm having the exact same problem.

Computer runs solid as a rock at 1066 with only the original 4GB installed, and runs stable with 8gb at 800, but for some reason, I just don't seem to be able to do 8gb @ 1066. According to Gigabyte, I should be able to do this. I'm stumped.
m
0
l
a b } Memory
June 17, 2011 10:13:24 PM

Gotcha. Yeah, I looked up your motherboard too. :)  According to specs, your CPU and motherboard should support your 8G of memory @ 1066.

Hey, did you try setting your timings to 6-6-6-15? And/or with the RAM voltage set to "default" or "auto" in the BIOS?

I think you should still run memtest86+ overnight just so you can completely rule out the RAM iteslf.

Installing Win7 on a spare HDD will similarly rule out a corrupt windows something-or-other.

I know these are not-clever, brute force methods but they're pretty definitive.

Ruling out RAM and then OS, you are left with BIOS, motherboard, and CPU. You can easily rule out (or fix) the BIOS by re-flashing your BIOS and resetting your CMOS (just for good measure). (I'm sure you know all this stuff). That's all I can think of.

Possibly check your motherboard manual for some odd BIOS setting that might have to do with RAM. Some Asrock boards have something you are supposed to enable to get some RAM to work right. I can't remember what it was called.
m
0
l
June 18, 2011 1:23:19 AM

eightdrunkengods said:
did you try setting your timings to 6-6-6-15? And/or with the RAM voltage set to "default" or "auto" in the BIOS?

I'll try that tonight. Why "6-6-6-15" though? I'm not familiar enough with DRAM timing to know what each does. I just go by the specs on the box. :) 

The voltage is back to default/auto now (1.8v), but at that speed, the top bus speed is 4x for 800MHz. To get 1066, I must use a multiplier of 5.3x, which requires a minimum of 2.1v. The auto setting defaults to 4x @ 1.8v. According to the specs and "CPU-Z", 5.3x requires 2.1v. I'll try 1.8v anyway just to see what happens.
m
0
l
June 18, 2011 3:31:07 AM

Update:

First tried leaving everything at Auto except setting the multiplier to 5.33x (* 200 gives 1066) and voltage of v2.1. Crash almost instantly after the Win7 desktop appears.

Tried 6-6-6-15 with a multiplier of 5.33x. Crash almost immediately after Windows starts.

"15" seemed odd to me, since the recommended 5-5-5-15 were all multiples of 5. So I tried 6-6-6-18. Lasted about a minute longer, but still crashed almost immediately after Windows starts.

Tried setting all the timings manually to the defaults for DDR2-800 and voltage @ 1.8v, except with the 5.33x multiplier. Same as leaving everything at Auto.

Searched online and found this alternate "solution" posted by G.Skill (http://gskill.us/forum/showthread.php?t=7764): Use timing of 4-4-4-12 with a clock of 4x (ie: 800MHz).

I don't know enough about timing to know if 4-4-4-12 @ 800 is as fast as 5-5-5-15 @ 1066, and Win7 is never stable at 1066 long enough to benchmark to compare it to 4-4-4-12, but it definitely is stable (using it now).
m
0
l
June 25, 2011 2:26:14 AM

eightdrunkengods said:
Gotcha. Yeah, I looked up your motherboard too. :)  According to specs, your CPU and motherboard should support your 8G of memory @ 1066.

Hey, did you try setting your timings to 6-6-6-15? And/or with the RAM voltage set to "default" or "auto" in the BIOS?

Sorry for the late follow-up. I've been in contact with "Gigabyte" to try and resolve the problem. Long story short, their "solution" is for me to "play with the timings until I find something that works." Gee. :( 

In my travels with Gigabyte Support, I tested each individual 2GB DRAM module, one at a time, clocked at 1066 @ 2.1v and tested with "MemTest86". Every stick tested perfectly.

I moved the two "new" DRAM's to slots 0/1, moved my older reliable memory to slots 2/3, and retested with "MemTest86" @ 1066. Again, errors occur in memory above 6GB. The problem clearly is not the memory itself.

So they had me test using the "on-board" video instead of my Radeon HD5850. Amazingly, "MemTest86" reported all 8GB tested perfectly @ 1066 and 2.1v. I even tried altering the timing (from "Auto" to 5-5-5-15), and it still all checked out okay. But I'm not going to give up my $200 video card just so I can run my ram at a slightly higher clock speed. So I'm back to 800MHz, but @ 4-4-4-12.

One interesting thing I discovered in all this: @ 4x (800MHz), "MemTest86" reads my CAS settings correctly. But @ 5.33x (1066MHz), a setting of 5-5-5-15 (set in BIOS), MemTest reports 8-5-5-15... three points higher. Ditto for a setting of 6&7 reporting as 9&10 respectively. Gigabyte says this is due to the way software reads the SPD default off the chips. Whatever.

I did find this post from a few years back (not the only one) to suggest Gigabyte motherboards have ALWAYS had a problem running more than 4GB @ 1066.

So I'll play around some more, but I doubt it will do any good. I still don't know why the video card is an issue or what to do about it, nor do I have a "working" starting point from which to start tweaking my Timings till I find out just how low I can go before 1066 "stops" working. With it working at 5-5-5-15 with on-board video, there's no reason the memory can't handle that speed while using my vidcard.

Gigabyte needs to figure this one out. I'm certainly not apt to buy another MoBo from them, nor recommend them to anyone else, if they don't.
m
0
l
a b } Memory
June 25, 2011 3:35:39 AM

Sorry about "6-6-6-15" I was recalling old DDR2 timings when I should have just looked them up. Obviously you got it worked out.

If you get bored, maybe try this: If your motherboard has a "memory remap" setting, make sure it's set to enable. Having it "disabled" usually manifests a totally different problem than what you're having. But, maybe worth a shot?

I think you are unlikely to notice a speed difference between 800MHz with CAS 4 vs. 1066 MHz with CAS 5. I kind of feel like any potential speed increase would be small and might be totally mitigated if you have to rewrite one email or lose 10 minutes of progress in a game due to a BSOD. Stability trumps minor speed increases, IMO. I came to this realization while trying to get my current RAM to run at 1600.
m
0
l
a b } Memory
June 25, 2011 1:06:22 PM

Can't help you with the RAM issue, but I can comment on the NTLDR on IDE drive issue.

When you install Windows 7 on an existing system, it will continue to boot from the old hard drive, but will be configured to start the new operating system from wherever you install it. That's just normal - don't worry about it.
m
0
l
June 27, 2011 1:40:46 AM

I spent a little time this weekend experimenting, and made some surprising discoveries.

Using "MemTest86", I attempted some very unscientific tests, testing my memory at various settings. Knowing that my memory passes all tests @ 1066 when using on-board video, I was able to do some comparing:

With the Multiplier set to 5.33x (* 200 = 1066) and my CAS timings set to 5-5-5-15 (which MemTest reads as 8-5-5-15), it took MemTest 7:35 to complete the first 4 tests.

At 800MHz (4x) and the CAS settings set to "Auto" (5-5-5-15), MemTest completed the first four tests in 8:10.

Again at 800MHz but with timing set to 4-4-4-12, MemTest completed the first four tests in 8:19 (you read that right. I probably could of gotten that down if I knew what other settings to tweak). I even re-ran the second test again to make sure. And 5-5-5-15 was indeed faster than 4-4-4-12.

I never unplugged my video card from its slot to do these tests. I simply moved the video cable to the DVI port on my motherboard and set BIOS to initiate it first. And in so doing, I noticed that, despite setting the BIOS to use "on-board video with shared memory", MemTest detected and tested NINE gigabytes of ram. I have to assume it was detecting the 1GB on the video card.

This got me thinking: "I wonder if I can still enjoy all the benefits of my video card even when using the on-board video port to connect my monitor?

Quick answer: No. It was worth a shot though. :) 
m
0
l
a b } Memory
June 27, 2011 3:54:50 PM

Mugsy said:

I never unplugged my video card from its slot to do these tests. I simply moved the video cable to the DVI port on my motherboard and set BIOS to initiate it first. And in so doing, I noticed that, despite setting the BIOS to use "on-board video with shared memory", MemTest detected and tested NINE gigabytes of ram. I have to assume it was detecting the 1GB on the video card.

This got me thinking: "I wonder if I can still enjoy all the benefits of my video card even when using the on-board video port to connect my monitor?


Ha. I have never noticed this with Memtest. I might run it later to see what mine does.
m
0
l
!