Sign in with
Sign up | Sign in
Your question

Slow SSD / Crashing

Last response: in Storage
Share
November 10, 2012 10:04:49 AM

hey guys,

I have been trying various solutions for around a week now but I can't seem to find an answer anywhere. I'm literally out of ideas now so any help would be greatly appreciated.

I have an Asrock N68C-GS FX motherboard, with a Corsair Force 3 64GB SSD attached as well as a 2TB stock drive and a 2.5" 80GB hard drive for testing purposes.

The biggest issue I seem to have is I have been unable to find a way to enable ACHI on my BIOS settings, which is the main reason I think of the resulting issue. I ran HDTune to test my hard drives data transfer rates and results are as follows:

Standard Hard Drive - 116 MB/s
Laptop 2.5" Hard Drive - 46 MB/s
Solid State Drive - 96 MB/s

Now I also noticed my hard drive is a SATA 3 and the highest my board supports is SATA 2 which would result in some slowing down however to be slower than a standard hard drive?

I have installed the SSD Controller drivers from the Asrock website, I have also tried 'forcing' ACHI by running a fresh Windows 7 installation in RAID mode (Span, Striped, and mirrored) among the SSD and Standard Hard Drive which resulted in several blue screens.

I checked and changed cables and the SSD is in the priority slot. I have also tried enabling RAID mode in regedit too which resulted in more blue screens.

One thing to note also is that during one test the SSD 'disappeared' until I restarted the computer, it wasn't listed anywhere on device manager, no event viewer messages, no device manager driver or anything. I also checked the surface of all drives for bad sectors again using HDTune which found ) errors.

I have ran Memtest86 for 3 passes with 0 errors also. The entire system is less than 5 months old using brand new parts.

Can anyone please offer any solutions other than 'buy a new mobo' please? With christmas just around the corner and several companies playing catch with my wallet that isn't really an option right now.

More about : slow ssd crashing

a c 86 G Storage
November 10, 2012 10:24:05 AM

You may have mixed up something here. Raid is not AHCI. Best way might be to start from scratch: disconnect the other drives, set AHCI in bios and install windows to the SSD. Make sure to have the Asrock AHCI driver on hand for installation.
November 10, 2012 10:37:19 AM

Sorry I think I said it wrong, what I meant was I forced RAID mode in an attempt to force ACHI mode because I read that RAID defaults to ACHI?

In my BIOS settings on the storage section I only have options for IDE and RAID only.
Related resources
a c 86 G Storage
November 10, 2012 11:06:18 AM

Well, i was to lazy to use google in the first place: the nvidia chipset on your board simple doesn't support AHCI.
November 10, 2012 3:09:32 PM

so new board it is then :( 

Thanks anyway
!