Newly Build PC Not Working!

Today I build a PC and as it was my first time I was a bit nervous however I got to a point where I thought it is finally finished so I plugged my monitor in using a HDMI cable, and once I powered it up bios didn't come up the only thing that happened was all the fans on all the components came on and a motherboard led and a PSU led. So the PSU is fine and so is the motherboard, so why is it doing this and how can I get bios to come up so I can install windows.

Extra Info:
There was no bios beep.
All the fans come on and stay on.
The motherboard led comes on and stays on.

I opened up the case and looked at the motherboard and wrote down all the names of the slots that aren't in use (don't have anything plugged into them.)
PWR_FAN
COM 1
SPDIF_OUT
LP1
CHA_FAN
IE1394_1
USB1112
IDE SLOT
USB78
6 answers Last reply
More about newly build working
  1. http://www.tomshardware.com/forum/261145-31-perform-steps-posting-boot-video-problems

    This thread is one of the better troubleshooting guides out there. Review and completed each item & report back if still having issues.
  2. Agreed ^
  3. I'm interested to know what you find as I am experiencing something similar. Although the reason I don't have beeps is because I don't have a system speaker (bought one today hopefully it comes soon).
  4. Pay close attention to #2 in that checklist. The symptoms you're desribing are exactly what would happen if you forget the 4/8 pin CPU power. It's usually located near the CPU socket and I/O ports.
  5. Nope the CPU power is in.
  6. Rashy said:
    Today I build a PC and as it was my first time I was a bit nervous however I got to a point where I thought it is finally finished so I plugged my monitor in using a HDMI cable, and once I powered it up bios didn't come up the only thing that happened was all the fans on all the components came on and a motherboard led and a PSU led. So the PSU is fine and so is the motherboard, so why is it doing this and how can I get bios to come up so I can install windows.

    Extra Info:
    There was no bios beep.
    All the fans come on and stay on.
    The motherboard led comes on and stays on.

    I opened up the case and looked at the motherboard and wrote down all the names of the slots that aren't in use (don't have anything plugged into them.)
    PWR_FAN
    COM 1
    SPDIF_OUT
    LP1
    CHA_FAN
    IE1394_1
    USB1112
    IDE SLOT
    USB78


    What are the system specs?
Ask a new question

Read More

Build Motherboards LED Monitor Systems