Sign in with
Sign up | Sign in
Your question

OCZ Petrol

Last response: in Storage
Share
November 11, 2012 2:49:47 PM

I bought 3 drives 3 weeks ago right when i purchased my new build pc. All ocz petrol drives (128gb).

One i use for my os drive. This drive has been absolutely perfect from the get go. Never a problem. However, the other 2, i have had to rma 3 times since then...

Is there some reccuring fault with these drives? Could it be my hardware is incompatible with the drives?

My Mobo is an asus p8z77-v lk. Cpu is a 2500k (ordered a 3750k, will arrive tomorrow :D ) and my PSU is an antec 850w High Current Pro.

I know for a fact it cant be my PSU as ive read all over about their stability and quallity. But i thought id just throw that up there anyway.

I am really finding it difficult to believe that these drives are at fault....by this point im assuming there must be some kind of issue between my motherboard and the drives.

Anyone else facing such problems with these?

More about : ocz petrol

November 11, 2012 4:21:41 PM

gzuz said:
I bought 3 drives 3 weeks ago right when i purchased my new build pc. All ocz petrol drives (128gb).

One i use for my os drive. This drive has been absolutely perfect from the get go. Never a problem. However, the other 2, i have had to rma 3 times since then...

Is there some reccuring fault with these drives? Could it be my hardware is incompatible with the drives?

My Mobo is an asus p8z77-v lk. Cpu is a 2500k (ordered a 3750k, will arrive tomorrow :D ) and my PSU is an antec 850w High Current Pro.

I know for a fact it cant be my PSU as ive read all over about their stability and quallity. But i thought id just throw that up there anyway.

I am really finding it difficult to believe that these drives are at fault....by this point im assuming there must be some kind of issue between my motherboard and the drives.

Anyone else facing such problems with these?


I should probably have pointed out that the issues im having are that the ssd will not show up in bios or in windows. System hangs at bios loading screen.
!