Sign in with
Sign up | Sign in
Your question
Closed

Has my card died??

Last response: in Graphics & Displays
Share
July 8, 2010 6:18:55 PM

Can some1 plz help??

it just started 5days a go when my the comp screen would go all haywire like this:
http://img693.imageshack.us/img693/2008/20100708184153....

then when i restart my computer i get this:

http://img4.imageshack.us/img4/986/20100708184728.jpg

it happens randomly as well surf the net the it hits or just asfter playing a game.
I've updated my graphics drivers to latest no effect. the only thing is that the idle temp hovers around 80c with fan at 40% been like that since i got it over year ago.

is my graphics card dead or something else??

spec:
Intel dule core E2180@2ghz
2gb RAM
ATI Sapphire 4850HD 512mb ()
psu @500w
motherboard: gigabyte GA-P31-DS3L/S3L

More about : card died

July 8, 2010 6:50:01 PM

Probably overheated, get a refund if you can and then buy a GTX460 when it comes out.
July 8, 2010 11:25:18 PM

PROBABLY??? if it's been like that for over a year then your lucky it didn't die in a couple weeks, return it as it should still be on warranty and they'll send you a new one.
Related resources
July 9, 2010 2:55:47 AM

Agree, if it under warranty then send it to get a replacement.
What is your PSU? brand? model?
July 9, 2010 3:30:02 AM

Try removing your GPU.
Plug your VGA display wire into your onboard slot.
Check if everything is ok. Also try a lowend Game on your onboard setting.

Also Run a memtest.

Reseat your GPU back in try again.

This way you can be narrow down the cause to your your GPU/Mainboard memory.



July 9, 2010 3:32:34 AM

optiv said:
Probably overheated, get a refund if you can and then buy a GTX460 when it comes out.

Stop Marketting. First try to root out the problem
September 5, 2012 9:55:08 AM

This topic has been closed by Mousemonkey
!