Sign in with
Sign up | Sign in
Your question

XFX Radeon 5770 Not Working on ASUS M4A78T-E

Last response: in Graphics & Displays
Share
July 9, 2010 10:47:39 AM

I recently (1 month ago) put together a new computer. I built it without any problems and have been using it as I had hoped to. Earlier this week, I purchased a "XFX Radeon HD 5770" graphics card, because I had only been using the built-in "HD 3300" and now wanted to do some slight gaming, but need the extra GPU power.

The problem:
As soon as I put the card in, and power on the computer I hear the GPU fan spinning at full speed. I can hear my computer boot, and run without any problems yet everything just seems to ignore the fact that a video card is there and continues to use the onboard video. Thinking the card was RMA, I stuck it in another PC and it worked. I coulldn't even hear the fan spinning. I don't know the exact specs of the other PC, but I know it had the same chipset (AMD 790GX) though it was a different brand MoBo. It loaded the drivers and even ran a game, no problems.

My next assumption was that my PCI-E x16 slot was bad but I found an older PCI-E card and threw it in my new build. That card worked fine. It installed it's drivers and had no errors. Then I tried my 5770 in the other, slower PCI-E x16 slot on my MoBo with no luck. In both PCI-E x16 slots the GPU fan spins at (what sounds like) full speed yet is not detected – during POST or by device manager in windows.
After that, I tried a number of things, including flashing the BIOS, diableing on-board graphics from the BIOS, resetting the CMOS (no video signal after disabling on-board even though card was in) and again just to see, removing ALL video card drivers (even those for onboard), reseating the memory, moving the memory to different slots (1&3; then 2&4), and of course reseating the card and rebooting numerous times.
I have a good bit of computer knowledge but this tricks me. When in the BIOS I don't exactly know what/where to “enable” my new card – if there is even an option for it. Under the default boot device in BIOS, “PCI-E” is selected. Also, a program came with the MoBo called “PC Probe II”. I went in to that and it states that the on-board “PCI-E x16 _1” is in use – even when I am only using the on-board and no other card is in the machine. Same with “AMD OverDrive”. In the “System Information-> Diagram-> it shows a PCI-E card but it is just my on-board.
I have connected the 6-pin power cable from my PSU to the 5770, yet even with it unplugged, the GPU fan still spins all the way. I also contacted ASUS for help and they told me there shouldn't be any compatibly issues with the card. I contacted XFX too but as of yet they did not respond.


My Rig:
- ASUS M4A78T-E AM3 AMD 790GX HDMI ATX AMD Motherboard
- AMD Phenom II X4 965 Black Edition Deneb 3.4GHz 4 x 512KB L2 Cache 6MB L3 Cache Socket AM3 125W Quad-- Core Processor HDZ965FBGMBOX
- SAMSUNG Spinpoint F3 HD103SJ 1TB 7200 RPM 32MB Cache SATA 3.0Gb/s 3.5" Internal Hard Drive
- G.SKILL Ripjaws Series 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model F3-12800CL9D-4GBRL
- Diablotek DA Series PSDA500 500W ATX Power Supply
- Microsoft Windows 7 Ultimate 64

Any help would be great, I am all out of ideas.
- Thanks, Anthony.
July 9, 2010 3:29:25 PM

i would start by bread boarding your setup. have just the essentials. i.e. cpu ram mobo power supply and gpu. reseat everything, make sure 6pin power is properly connected, make sure vga cable is hooked up correctly, and see what happens. The only things that comes to mind is power supply capacity or a minor fault in the power supply.
m
0
l
July 9, 2010 3:52:57 PM

You've already spent more time than I would trying to diagnose this. I would RMA the GPU in favor of an Nvidia card if you still can. Over the years, it seem to me anyhow, that these kinds of problems always involve ATI cards. My solution is to buy Nvidia.
m
0
l
Related resources
July 9, 2010 6:57:30 PM

HI all,

Thanks for the advice prelude2250.

Turns out I actually got it working. I swapped my motherboard with the one I tried it out on earlier. I swapped the processors so I'd have my Phenom II X4 and not the Athlon II X4. I then put the 5770 in my "new" system (only new thing was the MoBo) yet the Video card was still spinning full speed in my system and worked fine in the other system. That led me to the conclusion that the 6-pin power cable from my power supply was bad, so I put the one from the other computer in (both were 500w) and it worked like a charm. Seems like the "4-pin -> 6-pin" converter that came with the card didn't work either so maybe my power supply was maxing out somehow. But I digress, it works now and I thank you for your time to consider what might be wrong.
m
0
l
July 12, 2010 3:33:25 PM

it sounded like a power issue to me. Glad you got it fixed! Now go enjoy some DX11!
m
0
l
July 14, 2010 3:14:38 AM

I bought a Radeon HD 4650 XFX model w/ 1 gig ram and replaced a 5 year old 6600 GT w/ 256 ram and experienced a dramatic framerate loss. I went through the online support and while team was polite, I found them to be condescending, not respecting my experience, they suggested common knowledge and were downright flat on ideas to fix the problem. I would expect a team with as good a reputation as XFX to have original ideas and be willing to examine the situation from a unique point of view. I don`t believe there was a technical fault to the card mainly based on their confirmation that the 3dMark06 score being "more or less where it should be", I believe there was something wrong with the support, especially their unwillingness to examine any system info I provided. I tossed the card in the trash and re-installed the 6600 GT (and have been less frustrated) until I find a better card. Believe me, I will do more research this time. I would recommend to everyone to stay away from XFX
m
0
l
!