Linux - UT2004 - only init 5

Archived from groups: alt.games.unreal.tournament (More info?)

I did reconfigue my system to boot on init 3 level, then I noticed that
UT2004 doesn't work if I start the x server with
# startx
Only when the /etc/inittab default level is 5 UT2004 will start.

Does anybody have a solution for me beside level 5 init ;-)

GG
Kees
--
Many are called, few volunteer.
14:23:22 up 1:49, 3 users, load average: 0.15, 0.21, 0.41
Linux Registered User #300181 | ICQ #179658498
Visit me at http://www.xs4all.nl/~kostercd/ -- # EOE
7 answers Last reply
More about linux ut2004 init
  1. Archived from groups: alt.games.unreal.tournament (More info?)

    On 17 Nov 2004 13:24:00 GMT, Kees de Koster
    <root@dragonhill.xs4all.nl> wrote:

    >I did reconfigue my system to boot on init 3 level, then I noticed that
    >UT2004 doesn't work if I start the x server with
    ># startx
    >Only when the /etc/inittab default level is 5 UT2004 will start.
    >
    >Does anybody have a solution for me beside level 5 init ;-)
    >
    >GG
    >Kees

    Yes, use Windows.

    <Folk runs for the hills>
  2. Archived from groups: alt.games.unreal.tournament (More info?)

    In article <1g1np0l361rkdr7465kfc22ev8kjtsjchm@4ax.com>, Folk wrote:

    [...]

    >
    > Yes, use Windows.

    LOL :-S

    GG
    Kees
    --
    BOFH excuse #59: failed trials, system needs redesigned
    19:18:02 up 6:43, 3 users, load average: 0.15, 0.45, 0.89
    Linux Registered User #300181 | ICQ #179658498
    Visit me at http://www.xs4all.nl/~kostercd/ -- # EOE
  3. Archived from groups: alt.games.unreal.tournament (More info?)

    Kees de Koster enlightened us with:
    > I did reconfigue my system to boot on init 3 level, then I noticed
    > that UT2004 doesn't work if I start the x server with
    > # startx

    Well, why doesn't it start? What do you get in your log file? It's in
    ~/.ut2004/System/UT2004.log. Give us something to work with!

    MeltDown
    --
    !For all your UT99/2k3/2k4 questions visit UnrealTower's FAQ section:
    ! http://www.unrealtower.org/faq
    !Home of the FAQs for agut and agut2003.
  4. Archived from groups: alt.games.unreal.tournament (More info?)

    Kees de Koster enlightened us with:
    > Well here it comes ;-)

    I don't see anything wrong in the log file. What does UT2004 spit out
    on the console when you try to start it?

    > It seems like a GLX issue, the difference between startx and init 5
    > seems to that the x server runs with different permissions.

    I don't think so, but it might have set permissions in /dev/ the wrong
    way. I can't help you there, though, since you provided no information
    what so ever about you hardware or your OS. We're not psychic you
    know.

    MeltDown
    --
    !For all your UT99/2k3/2k4 questions visit UnrealTower's FAQ section:
    ! http://www.unrealtower.org/faq
    !Home of the FAQs for agut and agut2003.
  5. Archived from groups: alt.games.unreal.tournament (More info?)

    In article <slrncpokre.s51.meltdownUSE@sybren.thirdtower.com>, MeltDown wrote:
    > Kees de Koster enlightened us with:
    >> Well here it comes ;-)
    >
    > I don't see anything wrong in the log file. What does UT2004 spit out
    > on the console when you try to start it?
    >
    >> It seems like a GLX issue, the difference between startx and init 5
    >> seems to that the x server runs with different permissions.
    >
    > I don't think so, but it might have set permissions in /dev/ the wrong
    > way. I can't help you there, though, since you provided no information
    > what so ever about you hardware or your OS. We're not psychic you
    > know.
    >
    > MeltDown

    Thanks for coaching :-)

    The distro is Mandrake 10.0 with a nvidia FX 5700.

    In de logs from UT and XFree I didn't find a clue but in /dev/stderr I
    did find a message, "Error: Could not open /dev/nvidiactl because the
    permissions are too resticitive. Please see the FREQUENTLY ASKED
    QUESTIONS section of /usr/share/doc/NVIDIA_GLX-1.0/README for steps to
    correct."

    The relevant info from that file says:
    Q: OpenGL applications exit with the following error message:

    Error: Could not open /dev/nvidiactl because the permissions
    are too restrictive. Please see the FREQUENTLY ASKED QUESTIONS
    section of /usr/share/doc/NVIDIA_GLX-1.0/README for steps
    to correct.

    A: It is likely that a security module for the PAM system may be
    changing the permissions on the NVIDIA device files. In most cases
    this security system works, but it can get confused. To correct this
    problem it is recommended that you disable this security feature.
    Different Linux distributions have different files to control this;
    please consult with your distributor for the correct method of
    disabling this security feature. As an example, if your system has
    the file
    /etc/security/console.perms
    then you should edit the file and remove the line that starts with
    "<dri>" (we have also received reports that additional references to
    <dri> in console.perms must be removed, but this has not been verified
    by NVIDIA). If instead your system has the file
    /etc/logindevperms
    then you should edit the file and remove the line that lists
    /dev/nvidiactl. The above steps will prevent the PAM security system
    from modifying the permissions on the NVIDIA device files. Next,
    you will need to reset the permissions on the device files back
    to their original permissions and owner. You can do that with the
    following commands:
    chmod 0666 /dev/nvidia* chown root /dev/nvidia*

    So that was the solution, now it runs very smooth. In Mandrake I did
    also add a permission rule in msec otherwise the permission is set back
    again constantly.

    GG
    Kees
    --
    This is NOT a repeat.
    09:12:53 up 11:52, 4 users, load average: 0.20, 0.34, 0.20
    Linux Registered User #300181 | ICQ #179658498
    Visit me at http://www.xs4all.nl/~kostercd/ -- # EOE
  6. Archived from groups: alt.games.unreal.tournament (More info?)

    Kees de Koster enlightened us with:
    > So that was the solution, now it runs very smooth.

    Good! Nice that you figured it out on your own :)

    MeltDown
    --
    !For all your UT99/2k3/2k4 questions visit UnrealTower's FAQ section:
    ! http://www.unrealtower.org/faq
    !Home of the FAQs for agut and agut2003.
  7. Archived from groups: alt.games.unreal.tournament (More info?)

    Kees de Koster <root@dragonhill.xs4all.nl> wrote in
    news:slrncpmk7g.65d.root@dragonhill.xs4all.nl:

    > I did reconfigue my system to boot on init 3 level, then I noticed that
    > UT2004 doesn't work if I start the x server with
    > # startx
    > Only when the /etc/inittab default level is 5 UT2004 will start.
    >
    > Does anybody have a solution for me beside level 5 init ;-)
    >
    > GG
    > Kees

    Hey, can I come over and kick your ass for that icon you got saying "free
    palistine." How about freeing my boot from up your ass dickhead.
Ask a new question

Read More

Linux Video Games