BG2 - Unstable for me...

Archived from groups: comp.sys.ibm.pc.games.rpg,alt.games.baldurs-gate (More info?)

I'm having a lot of crashes seemingly at random with BG2. Just installed
SOA plus TOB, patched it up, and installed one fan fix, the Baldurdash fix
patch and the text update. This is the first time I've spent any time with
this game (yeah, I know... long story) so I don't know if the fix patch
might have something to do with it but I kind of doubt it. The problem may
be sound related, it seems as if there's a lot of sounds going on everytime
it crashes. However, I don't think I would much want to disable sound. Is
this a known issue or am I the only one?

Windows XP Pro SP 1
Asus K7V mobo
AMD Athlon 850 mhz
512 mb PC133 SDRAM
GeForce 2 mx 64mb
Sound Blaster Live! 5.1

I have all the performance sliders set to maximum.

I'm going to check for updated drivers next I think. It's not unplayable
but it is pretty annoying to have to keep restarting from a save. Needless
to say I'm abusing the quicksave button. :)

Other than the crashes this game is smellin' like a rose. The first dungeon
was just "okay" but everything after that has been pretty sweet.

--

Knight37

"I have an open mind.
Just not so open that the wind blows through."
-- Gerry Quinn, on csipg.rpg
10 answers Last reply
More about unstable
  1. Archived from groups: comp.sys.ibm.pc.games.rpg,alt.games.baldurs-gate (More info?)

    "Knight37" <knight37m@email.com> wrote in message
    news:Xns94CEB6EBC339knight37m@130.133.1.4...\

    > I'm going to check for updated drivers next I think. It's not unplayable
    > but it is pretty annoying to have to keep restarting from a save. Needless
    > to say I'm abusing the quicksave button. :)

    Have you tried disabling EAX sound?
  2. Archived from groups: comp.sys.ibm.pc.games.rpg,alt.games.baldurs-gate (More info?)

    Try going into control panel-sounds-change the sound scheme-audio tab.
    Then on the drop down list select a different device.
    Ian
  3. Archived from groups: comp.sys.ibm.pc.games.rpg,alt.games.baldurs-gate (More info?)

    Have you had any luck with running BG2 on your XP machine.

    I have just tried again to get it to work and keep getting annoying crashes.
    I have followed all the advice on patches and which patch to apply first
    etc. but I can not get the game to perform. I had no problems with my old
    Windows ME machine. Except that it was soooo slow that you could go make a
    cup of tea between rounds. I find this very annoying, I just get a machine
    that I can really enjoy playing the game on, and I get a different problem.


    "Knight37" <knight37m@email.com> wrote in message
    news:Xns94CEB6EBC339knight37m@130.133.1.4...
    > I'm having a lot of crashes seemingly at random with BG2. Just installed
    > SOA plus TOB, patched it up, and installed one fan fix, the Baldurdash fix
    > patch and the text update. This is the first time I've spent any time with
    > this game (yeah, I know... long story) so I don't know if the fix patch
    > might have something to do with it but I kind of doubt it. The problem may
    > be sound related, it seems as if there's a lot of sounds going on
    everytime
    > it crashes. However, I don't think I would much want to disable sound. Is
    > this a known issue or am I the only one?
    >
    > Windows XP Pro SP 1
    > Asus K7V mobo
    > AMD Athlon 850 mhz
    > 512 mb PC133 SDRAM
    > GeForce 2 mx 64mb
    > Sound Blaster Live! 5.1
    >
    > I have all the performance sliders set to maximum.
    >
    > I'm going to check for updated drivers next I think. It's not unplayable
    > but it is pretty annoying to have to keep restarting from a save. Needless
    > to say I'm abusing the quicksave button. :)
    >
    > Other than the crashes this game is smellin' like a rose. The first
    dungeon
    > was just "okay" but everything after that has been pretty sweet.
    >
    > --
    >
    > Knight37
    >
    > "I have an open mind.
    > Just not so open that the wind blows through."
    > -- Gerry Quinn, on csipg.rpg
  4. Archived from groups: comp.sys.ibm.pc.games.rpg,alt.games.baldurs-gate (More info?)

    "Silverlight" <silverlight@ntlworld.com> wrote in message
    news:ikoic.161$1H4.38@newsfe5-gui.server.ntli.net...
    > Have you had any luck with running BG2 on your XP machine.
    >
    > I have just tried again to get it to work and keep getting annoying
    crashes.
    > I have followed all the advice on patches and which patch to apply
    first
    > etc. but I can not get the game to perform. I had no problems with
    my old
    > Windows ME machine. Except that it was soooo slow that you could go
    make a
    > cup of tea between rounds. I find this very annoying, I just get a
    machine
    > that I can really enjoy playing the game on, and I get a different
    problem.

    The problem isn't Windows XPitself, it's some other part of your
    hardware setup and drivers.

    BG2 (and indeed BG1) works perfectly fine with Windows XP itself -
    several people, including myself, can verify this, and I'm using a
    straight-out-of-the-box install of Windows XP with no modifications
    apart from official Microsoft patches as and when I download them from
    windowsupdate.com.

    People have reported problems with certain graphics cards or sound
    cards though.

    Jonathan.
  5. Archived from groups: comp.sys.ibm.pc.games.rpg,alt.games.baldurs-gate (More info?)

    "Jonathan Ellis" <jonathan@franz-liszt.freeserve.co.uk> wrote in message
    news:c6d9j5$g4q$1@newsg4.svr.pol.co.uk...
    >
    > "Silverlight" <silverlight@ntlworld.com> wrote in message
    > news:ikoic.161$1H4.38@newsfe5-gui.server.ntli.net...
    > > Have you had any luck with running BG2 on your XP machine.
    > >
    > > I have just tried again to get it to work and keep getting annoying
    > crashes.
    > > I have followed all the advice on patches and which patch to apply
    > first
    > > etc. but I can not get the game to perform. I had no problems with
    > my old
    > > Windows ME machine. Except that it was soooo slow that you could go
    > make a
    > > cup of tea between rounds. I find this very annoying, I just get a
    > machine
    > > that I can really enjoy playing the game on, and I get a different
    > problem.
    >
    > The problem isn't Windows XPitself, it's some other part of your
    > hardware setup and drivers.
    >
    > BG2 (and indeed BG1) works perfectly fine with Windows XP itself -
    > several people, including myself, can verify this, and I'm using a
    > straight-out-of-the-box install of Windows XP with no modifications
    > apart from official Microsoft patches as and when I download them from
    > windowsupdate.com.
    >
    > People have reported problems with certain graphics cards or sound
    > cards though.
    >
    > Jonathan.
    >
    >
    Yes you are correct, I know people who are using BG2 on XP machines.

    I am probably just looking for a 'miracle' cure (which I know isn't
    available) to get round my problem. I do not have a fancy modified system,
    XP out of the box, but updated from windows update. Onboard sound (Realtek
    ALC650) with a Ge Force Fx5600 graphics card.

    The annoying thing for me is that one of the things that pushed me into
    investing my hard earned annual bonus into a new PC was to play BG2 at a
    good speed. When BG2 is running it works great, but it does spoil the fun
    when you are always waiting for the next crash. It adds a new sort of
    tension to the game when you move to a new area in the game, what will I
    find the other side if a door, and will the game still be running.

    Do you know what the best site is, that lists what issues have been found
    with BG2.

    Mark
  6. Archived from groups: comp.sys.ibm.pc.games.rpg,alt.games.baldurs-gate (More info?)

    "Silverlight" <silverlight@ntlworld.com> wrote in
    news:ikoic.161$1H4.38@newsfe5-gui.server.ntli.net:

    > Have you had any luck with running BG2 on your XP machine.
    >
    > I have just tried again to get it to work and keep getting annoying
    > crashes. I have followed all the advice on patches and which patch to
    > apply first etc. but I can not get the game to perform. I had no
    > problems with my old Windows ME machine. Except that it was soooo
    > slow that you could go make a cup of tea between rounds. I find this
    > very annoying, I just get a machine that I can really enjoy playing
    > the game on, and I get a different problem.
    >

    I am still getting occasional crashes. I've just learned to save often
    and deal with it, since there doesn't seem to be anything I can do to fix
    the problem. Sometimes it goes for hours without a crash, sometimes just
    a few minutes.

    Knight37
  7. Archived from groups: comp.sys.ibm.pc.games.rpg,alt.games.baldurs-gate (More info?)

    On 26 Apr 2004 12:57:20 GMT, Knight37 <knight37m@email.com> wrote:

    >"Silverlight" <silverlight@ntlworld.com> wrote in
    >news:ikoic.161$1H4.38@newsfe5-gui.server.ntli.net:
    >
    >> Have you had any luck with running BG2 on your XP machine.
    >>
    >> I have just tried again to get it to work and keep getting annoying
    >> crashes. I have followed all the advice on patches and which patch to
    >> apply first etc. but I can not get the game to perform. I had no
    >> problems with my old Windows ME machine. Except that it was soooo
    >> slow that you could go make a cup of tea between rounds. I find this
    >> very annoying, I just get a machine that I can really enjoy playing
    >> the game on, and I get a different problem.
    >>
    >
    >I am still getting occasional crashes. I've just learned to save often
    >and deal with it, since there doesn't seem to be anything I can do to fix
    >the problem. Sometimes it goes for hours without a crash, sometimes just
    >a few minutes.
    >

    Turning off some of the graphics features could help. IIRC the water
    effects didn't work well with my GF2 card on XP.


    --
    Hong Ooi | "My hate of d02 know no limit"
    hong@zipworld.com.au | -- asw, on rpg.net
    http://www.zipworld.com.au/~hong/dnd/ |
    Sydney, Australia |
  8. Archived from groups: comp.sys.ibm.pc.games.rpg,alt.games.baldurs-gate (More info?)

    "Hong Ooi" <hong@zipworld.com.au> wrote in message
    news:7q2q80tsugpmjnna58g9r4jht5gdipm5pj@4ax.com...
    > On 26 Apr 2004 12:57:20 GMT, Knight37 <knight37m@email.com> wrote:
    >
    > >"Silverlight" <silverlight@ntlworld.com> wrote in
    > >news:ikoic.161$1H4.38@newsfe5-gui.server.ntli.net:
    > >
    > >> Have you had any luck with running BG2 on your XP machine.
    > >>
    > >> I have just tried again to get it to work and keep getting annoying
    > >> crashes. I have followed all the advice on patches and which patch to
    > >> apply first etc. but I can not get the game to perform. I had no
    > >> problems with my old Windows ME machine. Except that it was soooo
    > >> slow that you could go make a cup of tea between rounds. I find this
    > >> very annoying, I just get a machine that I can really enjoy playing
    > >> the game on, and I get a different problem.
    > >>
    > >
    > >I am still getting occasional crashes. I've just learned to save often
    > >and deal with it, since there doesn't seem to be anything I can do to fix
    > >the problem. Sometimes it goes for hours without a crash, sometimes just
    > >a few minutes.
    > >
    >
    > Turning off some of the graphics features could help. IIRC the water
    > effects didn't work well with my GF2 card on XP.
    >
    >
    > --
    > Hong Ooi | "My hate of d02 know no limit"
    > hong@zipworld.com.au | -- asw, on rpg.net
    > http://www.zipworld.com.au/~hong/dnd/ |
    > Sydney, Australia |

    Turn off the EAX sound first. Just use the basic sound option. I recall
    this was the source of crashes whan I played the game, I disabled it early
    and had no crashes after.
  9. Archived from groups: comp.sys.ibm.pc.games.rpg,alt.games.baldurs-gate (More info?)

    "Knight37" <knight37m@email.com> wrote in message
    news:Xns94D750ED22516knight37@130.133.1.4...
    > "Silverlight" <silverlight@ntlworld.com> wrote in
    > news:ikoic.161$1H4.38@newsfe5-gui.server.ntli.net:
    >
    > > Have you had any luck with running BG2 on your XP machine.
    > >
    > > I have just tried again to get it to work and keep getting annoying
    > > crashes. I have followed all the advice on patches and which patch to
    > > apply first etc. but I can not get the game to perform. I had no
    > > problems with my old Windows ME machine. Except that it was soooo
    > > slow that you could go make a cup of tea between rounds. I find this
    > > very annoying, I just get a machine that I can really enjoy playing
    > > the game on, and I get a different problem.
    > >
    >
    > I am still getting occasional crashes. I've just learned to save often
    > and deal with it, since there doesn't seem to be anything I can do to fix
    > the problem. Sometimes it goes for hours without a crash, sometimes just
    > a few minutes.
    >
    > Knight37

    Using the BG Config program I set my system up as an average PC with 3D
    acceleration, and the only other change I made was to the rules to Core D&D.
    I'm not sure what difference on options this has made, as previously I had
    set my system up with all the sliders on maximum. But last night I didn't
    have one crash. I'm not quite ready to celebrate yet, I will still be
    making lots of saves, but it does seem more stable.
  10. Archived from groups: alt.games.baldurs-gate (More info?)

    Knight37 wrote:
    > I'm having a lot of crashes seemingly at random with BG2. Just
    > installed SOA plus TOB, patched it up, and installed one fan fix, the
    > Baldurdash fix patch and the text update. This is the first time I've
    > spent any time with this game (yeah, I know... long story) so I don't
    > know if the fix patch might have something to do with it but I kind
    > of doubt it. The problem may be sound related, it seems as if there's
    > a lot of sounds going on everytime it crashes. However, I don't think
    > I would much want to disable sound. Is this a known issue or am I the
    > only one?

    What's the fan fix? Not seen this one before.
    The first thing I would try is disabling 3d fx. It makes such a small
    difference to the game
    it is hardly worth it.

    If this makes no difference to the frequency of crashes, try disabling the
    EAX.

    If this makes no difference to the frequency of crashes, you could disable
    your sound card / drivers completely
    from windows and then run the game. This will either confirm it is the sound
    driver or something else that is causing the game to crash.

    After this, you could try modem drivers if you are on dial up, I used to
    have troubles with modem drivers crashing machines, let alone games.

    > AMD Athlon 850 mhz
    > I have all the performance sliders set to maximum.

    Should be fine, I am running on Athlon 800 and it flies at maximum.

    > I'm going to check for updated drivers next I think. It's not
    > unplayable but it is pretty annoying to have to keep restarting from
    > a save. Needless to say I'm abusing the quicksave button. :)

    Latest drivers are nearly always a good thing.

    > Other than the crashes this game is smellin' like a rose. The first
    > dungeon was just "okay" but everything after that has been pretty
    > sweet.

    The improved Illyich mod would have made the first dungeon more than ok :-)

    --

    Rich (change nospam to mlu035 to reply direct)
Ask a new question

Read More

Games Video Games