Sign in with
Sign up | Sign in
Your question
Closed

Radeon HD 3650 Woes

Last response: in Graphics & Displays
Share
July 10, 2010 2:34:10 PM

My Geforce 7600GS AGP burnt itself up so I bought a Sapphire Radeon HD 3650 AGP card to replace it. Inserted the card, booted up, installed drivers, restarted, and now it will ONLY display in 4-bit (?) color at 640x480. If I uninstall the drivers and restart it works a little better.

I do have some ATI drivers still on my computer, so says Driver Sweeper, but when I try to remove them it says "access denied," even when the card is unplugged and I'm using my onboard graphics.

One more thing, occasionally when I have this card plugged in my computer seems to refuse to post. I hit the power button, fans and eveything (including the video card) come on, and nothing happens. I usually have to remove and replace the card in order for the computer to post.

Any thoughts? Later I'm going to remove my sound card and try that, I've heard bad things about SB soundcards and AGP video cards.

More about : radeon 3650 woes

July 10, 2010 11:41:17 PM

Update: I just tried using Atitool to see if it would shed any light on the matter. It made my system hang and ran my CPU up to 99%. When I hover over the icon it says:

Core: #J Mhz
Mem: #J Mhz

Any idea what this means? I thought maybe it was some hexidecimal gibberish. I've tried AGP hotfix drivers, AMD's drivers, Sapphire's drivers, and even Omega drivers, nothing seems to work, my computer just doesn't seem able to communicate with this card properly.

I'm thinking I'm just going to return it (barring any issues with Newegg) and get another 7600GS to replace my burnt out one.
Score
0

Best solution

December 8, 2011 9:28:20 PM

After bashing my head against a wall for about ten hours today, I finally discovered the cause of a similar problem (640x480 4-bit graphics with newer drivers, very sluggish and unreliable performance with older drivers): the AGP aperture setting in the BIOS. Apparently, it needs to be at 128MB, or, even better, 256MB. That cured all my problems.
Share
December 15, 2011 10:58:15 PM

Best answer selected by SpamShadow.
Score
0
!