Sign-in / Sign-up
Your question
Solved

Failing Video Card?

Tags:
  • Graphics Cards
  • Graphics
Last response: in Graphics Cards
July 11, 2010 5:07:21 PM

Yesterday while playing BC2 my screen began to flicker. I could see in the background the BC2 splash screen, I have full movement of the mouse, and I am able to launch the game or get into a server, but the screen would flicker. I tried a few other games and I'd get the same flickering. However, when I load a video or home movie, everything is fine. I uninstalled 10.6 and reinstalled it a few times, both with and without driversweeper, removed both cards to test each one (seems to work fine with each individual card). I thought I finally fixed it, as this morning when I was playing, I didn't get any flickering. However, at one point, my screen went black playing BC2. Not completely black, I could still see things like my squad mates, the chat box, and my weapon status on the lower right. Sounds were loud and clear, and I can see the target reticule. When I would do sudden movements, the screen would go back to normal, but if I stop at any point, the picture goes black again. Thoughts? I've had my xfire setup for about a month now, had some issues with 10.6 drivers, but nothing of this magnitude.

Also, while I'm at it, Since I've been in xfire, and installed 10.6, I can't find CCC anywhere. Installation log says it installed successfully, but I don't see it when I R-click my desktop or anything. Tried numerous times to uninstall/reinstall drivers, from amd's site as well as installed drivers straight from the disc, but CCC is nowhere to be found. GPU-Z says both cards are enabled, but no CCC. Any help on either of these would be appreciated. Thanks.

Specs:

i5-750 (oc'ed 3.5ghz)
asus p7p55d pro
4 gb g skill ripjaws 1600
xfired 5770s
600w antec psu.

Like I said, for about a month xfire was running smooth as butter but not it's a bit funky.

**I'm running at 1920*1080 resolution but I'll try bumping it down to see if that helps.

More about : failing video card

a c 197 U Graphics card
July 12, 2010 4:29:32 AM

Try the older drivers like 10.5 or 10.4
Also try each your card individually, see which one is in trouble...
m
0
l
July 13, 2010 4:32:37 AM

Thanks for the response. I've tried 10.5. Actually 10.5 was the sweet spot for my setup. 10.6 just jacked everything up. Both cards appear to be working properly individually, so I'm guessing it's either xfire setup-poor drivers, or as someone mentioned in a previous thread, a power issue. Kinda weird that it just started happening recently, around the time I bought the THQ pack from steam and installed 10.6.
m
0
l
Related resources

Best solution

a c 197 U Graphics card
July 13, 2010 9:30:05 AM

So stay with 10.5, since it's the most stabilize driver for your setup...
Sometime the older driver can be more stable than the newest one... :) 
Share
July 21, 2010 3:23:18 PM

Best answer selected by thestrangebrew.
m
0
l