Sign in with
Sign up | Sign in
Your question
Solved

DRAM timing problems

Last response: in Memory
Share
June 23, 2011 4:36:40 AM

My http://www.memoryexpress.com/Products/PID-MX25526(ME).aspx
RAM sticks are having a problem, which is why I'm currently posting here.

The timings are not staying.

I set the timings as 7-7-7-20 in the bios and it went good for that bootup.

Next bootup it changed back to 7-9-9-24, and I went WHAT?! for a good hour.

After that it went back to 9-9-9-24 and I was disappointed.

Any suggestions guys?

More about : dram timing problems

a b } Memory
June 24, 2011 8:42:23 PM

It sounds like the timings are set on auto and it changes it back from what you had it set on. Turn off auto if it is on and set it to manual and save bios on exit..
m
0
l

Best solution

a c 347 } Memory
June 24, 2011 9:05:31 PM

The Goal 1333MHz 7-7-7-20 @ 1.65v

BIOS:
DRAM Frequency -> 1333 MHz
DRAM Timing Frequency /Enter
DRAM CAS# Latency -> 7
DRAM RAS# to CAS# Delay -> 7
DRAM RAS# PRE Time -> 7
DRAM RAS# ACT Time -> 20
--
DRAM Timing Mode -> 2N

DRAM Voltage -> 1.65 ; or closest value e.g. 1.64 per menu

Save & Exit = Yes

Good Luck!

Share
Related resources
June 24, 2011 9:08:38 PM

Those RAM are rated "XMP Ready"

Try and find that option in your BIOS and select "XMP Profile 1". Then save it and you should have absolutely 0 problems as the timings will automatically be set to patriot's specifications.
m
0
l
a c 347 } Memory
June 24, 2011 9:10:05 PM

AMD doesn't support XMP, only Intel does ;) 

Sooo Manually or Auto.
m
0
l
a c 347 } Memory
June 24, 2011 9:56:53 PM

Try the settings exactly as I posted above.

The 'Sooo Manually or Auto' was to @Drakoes regarding XMP.
m
0
l
June 24, 2011 10:27:35 PM

Yeah i preset everything, It changes back for some apparent reason.
m
0
l
a c 347 } Memory
June 24, 2011 10:48:08 PM

On CPU-Z is this the screen you're seeing? CPU-z http://www.cpuid.com/softwares/cpu-z.html

If you have some Timing App, OC App e.g. AMD Overdrive, or ANY BIOS invasive App then yeah it's change your BIOS. It's the only explanation other than a bad COM Battery. Those Apps are crap so don't use them, you get stuff like this, overriding the BIOS.

1. Uninstall the Apps(s), 2. Try MSCONFIG -> select Diagnostic and reboot.

m
0
l
June 26, 2011 2:27:59 AM

My DC mode (not sure what that is) says unganged...
DRAM Freq is 655.6 (it's fine)
FSB: DRAM is 3:8
and instead of Row Refresh cycle time I have something called "Bank cycle time" (tRC) and thats at 20 (any ideas on what that is?)

Yeah...
m
0
l
a c 347 } Memory
June 26, 2011 6:04:56 PM

Ganged and Unganged is a normal characteristic of AMD; I posted a generic Intel example. 655.6 * 2 = 1311.2 MHz for the RAM Frequency. This is due to FSB fluctuation and is normal.

"Bank cycle time" (tRC)" is a CPU-z characteristic again for AMD; see http://en.wikipedia.org/wiki/Memory_bank

If you set the 7-7-7-20-2T {same as 2N} then that's what you should see :) 

In order from the top down and in the timings column, you should see:
655.6 {number varies}
3:8
7
7
7
20
--- (tRC) ; this is set by BIOS
2T

Otherwise post a an image.
m
0
l
June 26, 2011 7:07:05 PM

Mine's 1T but that doesnt make a difference.

It has stopped changing back for a bit, which is good. And it matches.

...So far
m
0
l
a c 347 } Memory
June 26, 2011 8:33:42 PM

If your system is stable at 1N/1T then leave it otherwise use what I posted "DRAM Timing Mode -> 2N".

Your FSB will ALWAYS have some degree of fluctuation, to conserve energy your MOBO changes the CPU Multiplier and to some degree the FSB comes along for the ride. There are VERY, VERY few values that don't bob up and down depending on stress of the CPU.
m
0
l
July 3, 2011 1:54:50 AM

Best answer selected by stupiditystrikes.
m
0
l
!