Sign in with
Sign up | Sign in
Your question

RMA my 4850?

Last response: in Graphics & Displays
Share
July 12, 2010 4:57:33 AM

I added an ASUS 4850 to my new build and had two completely different artifacts. The first came after I installed the vid card. I installed the latest drivers (10.6) and blue dots started appearing in Firefox and later on the desktop. I reinstalled the drivers that came with the card (8.7) but still no good. Uninstalled the card and tried the onboard video (integrated 4200) but same thing. The artifacts disappeared the following day for whatever reason when using the onboard video. I reinstalled the 4850 with 8.7 and no problems. A week later a new artifact problem emerged. The desktop changed to multiple colors and the screen was flickering. I restarted the computer and the problem went away. I've had no problems with games (newest played was Bioshock). My idle temp is 34C and peek during Bioshock was 58C (GPU-Z).

What tests should I run to see if my vid card is bad? It seems odd it only artifacts under no stress.
Should I RMA this card back to Newegg?

System Specs

ASUS Radeon HD 4850 1GB 256-bit DDR3
Western Digital Caviar Blue320GB 7200 RPM SATA
G.SKILL 4GB (2 x 2GB) DDR3 1333 (PC3 10666)
AMD Athlon II X3 435 Rana 2.9GHz
ASUS M4A785TD-V EVO AM3 AMD 785G
Antec Three Hundred Illusion
OCZ StealthXStream OCZ700SXS 700W ATX12V / EPS12V

Thanks

More about : rma 4850

a c 153 U Graphics card
July 12, 2010 5:02:30 AM

When you were changing between drivers did you clean them out before you installed them? Especially when you went "backwards". That could have a major effect. I reccomend using driver sweeper to clean all your amd/ati drivers and install the latest one again.

Might as well try that before you go and RMA. How long ago did you purchace it?
m
0
l
Related resources
Can't find your answer ? Ask !
July 12, 2010 3:00:59 PM

I purchased the card on 6/30. I will definitely try drivesweeper first.

thanks
m
0
l
July 12, 2010 4:32:48 PM

good call
m
0
l
July 25, 2010 9:00:56 PM

Sorry for the late update but I ran drivesweeper, reinstalled the original drivers, and I have not seen the artifacting since. A new problem did appear. At randoms moments on the desktop or in Bioshock the screen will go completely black for five seconds and return to normal.  I updated the drivers to Asus's latest 8.711 and witnessed the same problem using Firefox last night.

I browesd ASUS's forums but I didn't find a solution.

Could this be a problem with the onboard integrated 4200?  An older monitor (2 yr. old)?  Windows 7 64bit?

I would really hate to RMA.

Thanks again for the help
m
0
l
!