Dvd drive plays movies, gives me permissions error if I explore disc

Drive will play movies fine, but if I try to explore the disc it gives me a windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item error. It's also impossible to rip or create images from dvds on this drive so I can no longer do disc to disc burns and have to rely on making images from my 2nd drive.

If I put the same disc in my 2nd drive it works fine. Non-movie dvds (video games, driver discs) can be explored with no issue whatsoever.

I run windows 7 and have the dvd region set to 1. I have tried uninstalling and reinstalling the drive via the device manager but it had no effect.
5 answers Last reply
More about drive plays movies permissions error explore disc
  1. You need to log in as administrator , if this is your computer then you should make your user name the administrator and that way you can access any of the functions of the computer's operating system.
  2. I am an administrator. I can also explore video game and driver dvds in it with no issue. Also, as I mentioned earlier, I can put the same exact same dvd in my 2nd dvd drive and explore at will with no issues. Only movies are giving me problems. If it was a rights issue wouldn't I be getting the same error on my 2nd drive?
  3. I enable the secret admin account just to see if that would make any difference. Logged on to it and noticed that when I use that account there are duplicates of my optical drives. It shows 4 instead of 2 although they're duplicates not new drive letters. Is that an indication of anything?

    Also the drive in question still gets the same error if I have a movie dvd in.
  4. Then there is a setting in the second dvd drive that is different from the first one that is giving you the problem. Are both drives the same , brand , model ?
    When you delete or remove something from the computer the best way is to empty the recycle bin and shut down the computer and not do a restart , that way your OS is not grabing settings from the recycle bin intead of where it's supposed to. So then turn the computer back on and reinstall the drive. If there are drivers for the dvd drive on the manufacturers web page you could download those before deleting the drive so Windows could load those instead of what it has.
  5. POST UPDATED WITH SOLUTION

    Original Post

    I am admin on my PC and as such have all rights permissions (Full Control) but as of today I get this error message on every DVD or Blu-Ray disc I insert into my machine. Autoplay no longer functions for me with movie discs anymore. I have tried googling but it seems nobody has a solution. I used to have this issue but coiuld only fix it by reformatting the boot drive and doing a clean reinstall of Windows 7. That is a complete nightmare and I wish not to do that again.

    How can I fix this annoying glitch without wiping my boot drive and reinstalling windows. I fail to understand what the cause is.

    this happens with both physical movie discs and disc images (ISO's) of movies. I discovered this by making an ISO of a blu-ray disc and mounting it as another drive. The issue persists.

    SOLUTION

    I just found a solution for me. I edited the autoplay properties and the section for dvd and blu-ray was to open a program not pertaining to playing movies. I fixed it by setting the autoplay to use Arcsoft Total Media 5 for DVD and for blu-ray disks (you can point to other DVD/Bluray players if you have a different one) and now the problem is solved for me. I hope this helps others out there.
Ask a new question

Read More

DVD Drives Movies Permissions Storage