Sign in with
Sign up | Sign in
Your question

IDE HDD Master with SATA HDD SLAVE?

Last response: in Storage
Share
November 17, 2012 7:13:41 PM

Hello thank you for taking the time to review my post. I apologize if I use improper technical jargon and hope my explanation is translatable.

-

I am trying to install a western digital hard drive, Model WD5000AAVS [ http://support.wdc.com/product/install.asp?groupid=608&... ] ( very last model listed ) into my Dell Dimension 8300, as an extra hdd for storage use only.

The hard-drive is from a western digital my book 500GB external hard drive, Model WD5000H1U-00.

I purchased an adapter [ http://www.amazon.com/dp/B002Y2NI4M/ref=pe_175190_21431... ] so I could attach the WD HDD to the IDE cable inside of my Dell Dimension 8300.

I attached the IDE HD1 cable (black) into my primary boot drive, and then attached the IDE HD2 cable (gray) into the adapter which connects to the Sata port on the WD HDD. Then connected both power supply cables to the two drives. (power is good and some form of data is being sent to the motherboard)

When I power on the computer I get error message:

Primary Hard Drive Disk 0 Not Found
Press F1 (reboot) F2 (setup)

I enter setup and under drive configuration it reads:

Drive Configuration //

Primary Master Drive: unknown device
Primary Slave Drive: off

IDE Drive UDMA: on

Boot Sequence //

check 1. Diskette Drive
check 2. IDE CD-Rom
check 2. Hard disk drive (not installed)

It was suggested online to try ALT + E,F,B. The system reboots, performs the Automatic IDE Configuration, but will not boot windows. Checking the bios the new drive configuration is:

Drive Configuration //

Primary Master Drive: OFF
Primary Slave Drive: OFF

IDE Drive UDMA: on

Boot Sequence //

check 1. Diskette Drive
check 2. IDE CD-Rom

I have the original Hard Drive set to "Cable Select" on the jumper slot. The WD HDD did not come with a mini-jumper and underneath the hard-drive where the jumper selection might be written, there is no verbiage to indicate master/slave/ or cable select.
_

If I remove the IDE HD2 from the Adapter connected to the WD HDD, reboot, command ALT E,F,B; my computer will boot off the original hard-drive and open windows, so no issue there, I just can't seem to figure out how to load up the WD HDD...

Hope someone can help! Thank you.
November 17, 2012 8:55:25 PM

I don't know if this will help (or if you've already done this) but I did note on the adapter page - the comment on the far right photo - to keep the pins on the adapter from touching the sides of the hard drive (that's the power input and will short the hdd) that's something to check
November 18, 2012 3:47:48 AM

Thanks C12Friedman, I did not see the information regarding keeping the pins from the side of the hhd, I will wedge the adapter.

The drive is still working and has not shorted out.
Related resources
a c 271 G Storage
November 18, 2012 6:07:19 AM

I suspect that the IDE device on the adapter is configured as a Master, in which case it cannot coexist on the same IDE cable as another Master.

It's difficult to make out the writing above the Molex connector, but there appears to be a jumpering scheme that looks like this:

MS --- JP0-NC, JP1-NC
SL --- JP0-1, JP1-NC
CS --- JP0-1, JP1-1

... where NC = Not Connected and 1 = jumper installed

... and MS/SL/CS = Master / Slave / Cable Select

http://www.amazon.com/gp/customer-media/product-gallery...

ISTM that you would need to solder a wire link at JP0 in the unpopulated 4-pin jumper block. That would make your adapter a Slave IDE device.
November 18, 2012 3:55:48 PM

Fzabkar, thank you for taking a look! I just re-examined the adapter and noticed that there was a jumper pin for slave/master on the adapter. I was stuck trying to work with the jumper pins on the Sata Hard-Drive (which are not slave/master pins), and wasn't even looking on the actual adapter.

I'm going to try out the drive again, and I hope it is as simple as a mini jumper oversight.

This is the first time I've worked with installing a hard-drive so forgive me for my ignorance.
November 18, 2012 4:37:09 PM

Changed the jumper on the adapter to slave, then tried the IDE Master HDD as both Master and Cable Select. No change in the setup, when turning the computer on still receive;

Primary Drive 0 Not Found
Primary Drive 1 Not Found

:( 
a c 140 G Storage
November 18, 2012 5:30:51 PM

I could be wrong, but does the 8300 not have SATA ports anyway?

http://support.dell.com/support/edocs/systems/dim8300/s...

With older systems(and maybe even that adapter if it is for 1.5gigabit sata and your drive is 3gigabit/sec), The hard drive it self has jumpers to set SATA 1.5gigabit mode. You may have to set that as well.
http://wdc.custhelp.com/app/answers/detail/search/1/a_i...

If not, Maybe just try one device at a time and see what it does. You boot drive can and will work as a slave(just has to be set to boot in the bios) if the adapter will not let you be slave.
!