Sign in with
Sign up | Sign in
Your question

Windows 64 bit saying 4gigs ( 2 usable)

Tags:
Last response: in Memory
Share
June 25, 2011 1:35:56 AM

ok i just got my new system and installed everything my self and loaded windows 7 on to it and it told me that i had 4 gigs memory then i started to do some updates to drivers and such and now its saying i have 4gigs but only 2 useable.

any help on how to get my full 4 gigs

oh and ps when i go into my resource monitor and look at memory it said there is 2049mb reserved for hardware, as well i dont think my cpu has a bent pen since it said before that i had the full 4 gigs


a b } Memory
June 25, 2011 2:17:32 AM

Click Window icon>type in msconfig in search>press enter

in system configuration go to boot tab>advance options>untick the maximum memory box>OK
m
0
l
June 25, 2011 2:22:34 AM

still hasent fixed it
m
0
l
Related resources
a b } Memory
June 25, 2011 2:24:40 AM

Did you restart?
m
0
l
a b } Memory
June 25, 2011 2:32:31 AM

List your full system spec and window version
m
0
l
June 25, 2011 2:36:10 AM

ok
MSI 870-G46 6gb/s ddr3 800/1333/1600
GSKILL 4gigs ripsaw ddr3 1600
am3 phenom II 1100T 3.3ghz hex core
seagate 500Gb 6gb/s
NZXT M59
HD4350 512mb ddr2 640mhz core clock 440mhz memory clock
m
0
l
a b } Memory
June 25, 2011 2:41:06 AM

Try to remap memory on your mobo.
m
0
l
June 25, 2011 2:42:07 AM

as in reseat them in different slots?
m
0
l
June 25, 2011 3:07:37 AM

allright this seems to be what happend to me how would i tell my graphics card not to reserve 2 gigs of my ram? * yesterday is when i built my system so i was installing drivers then and this did seem to happen after i installed my graphics drivers *
m
0
l
a b } Memory
June 25, 2011 3:17:24 AM

You get the system to reserve less ram for gpu by remap ram if there is a option on your bios. If you don't have that in bios, try another driver.
m
0
l
June 25, 2011 4:42:32 AM

ok i have reinstalled windwos 7 and it is still saying 4 gigs ( 2 usable )
m
0
l
a b } Memory
June 25, 2011 8:47:02 AM

Did you use a different graphics driver?
m
0
l
June 25, 2011 8:02:15 PM

yes i did i have tried drivers from HIS * my maker of the card * and amd/ati and still nothing
m
0
l
June 25, 2011 11:12:02 PM

ok so i just noticed when i boot up and i see the post it is saying there is only 2 gigs of ram. what would the remap ram be in my bios im not sure i cant find it
m
0
l
June 25, 2011 11:14:46 PM

now that i think about it this never really started till i updated my Bios is there a chance that my bios is messing all this up?
m
0
l
a b } Memory
June 26, 2011 12:15:53 AM

If your mobo sees 2GB ram, remap won't help. I suggest fill the ram slot one by one to boot to find out the problem.
m
0
l
June 26, 2011 3:42:38 AM

ok so i tested each ram stick and both worked just fine do you think that the bios update i did is reserving the 2 gigs for hardware?
m
0
l
a b } Memory
June 26, 2011 3:43:32 AM

I think it is. Roll back the bios.
m
0
l
June 26, 2011 5:02:20 AM

how would i do that?
m
0
l
a b } Memory
June 26, 2011 5:06:56 AM

Flash your bios back to the version which can use 4GB.
m
0
l
June 26, 2011 5:41:43 AM

so if my bios updates through usb do i just do that but with a older version and that wont break anything?
m
0
l
a b } Memory
June 26, 2011 5:58:43 AM

Yes, load the older bios to usb and flash the bios again. Just like your updates, but this time, using an older bios, so a downgrade.
m
0
l
June 26, 2011 6:24:22 AM

YES we where right it was the bios :D  :D  :D  :D  :D  i'm so happy to have my 4 gigs back thank you sooooo much i really owe you for this but the sad news on that is i just spent a ass load on my comp and don't have any money now XD thank you thank you thank you
m
0
l
a b } Memory
June 26, 2011 6:28:09 AM

No problem. I am sure if I didn't take up the job, someone from this forum will happily assist you and solve the problem anyway, so really it was nothing special. But you're welcome.
m
0
l
!