Closed

GPT initializing poblem

Hi, I've just upgraded my system and bought a 3TB and a 4TB HDD to keep things tidy.
My problem is; I can use GPT system just fine but I can not move the disk. As long as it's connected to the same socket/cable, everything's fine, but if I move it to another SATA or USB, I can not the access the disk, so Windows needs to initialize the disk again and if I do that I need to partition the drive which means I lose the contents!

As you would agree, this is not a reliable way to store important files, since a system failure, upgrade or changing the PC, etc. means I lose everything on the disk!

My PC: Windows 7 Ultimate 32bit, Gigabyte X79 MBU, 4GB RAM, everything should be up-to-date...

A few notes;
- I can use the entire disk size (3TB/4TB) and everything works great as-long-as I do not move it
- The method I use: Disk Management initializes the disk, I choose GPT, then basic partition and I use the entire space on it...
- No, I'm not trying boot from it or use it on Win XP or use it with any RAID config, etc. Just using it as a basic storage drive.
- No, I can not use them as 2TB+1TB or 2TB+2TB partitions because apparently the 2TB limit is not per-partition but per-drive.
- Both disks act like this on SATA-III, SATA-II, USB3.0 and USB2.0, and I tried every combination, all acted same.

From what I read from official pages, on an up-to-date PC with Windows 7, it should behave just like an MBR system disk , but this strange behavior proves otherwise.

Does anyone know what am I doing wrong?
6 answers Last reply
More about initializing poblem
  1. You're positive it doesn't just need a drive letter assigned to it after you've moved it ?
  2. Absolutely!
    When I start Disk Manager, immediately a window pops up and asks for the system; MBR or GPT. If I cancel that window and right-click the disk (left section), only choices I have are;
    Start/Activate Disk, Offline, Properties, Help (It's not English, so I've translated these).
    If I right-click the right section (the area which shows the bar with the disk space) there are partition-type choices but they are greyed-out if I don't choose "Start/Activate Disk" first. There's no drive-letter assignment choice unless I format the disk the way I described.

    Thanks for the quick answer though...
  3. Have you found a solution for this?
    I am having the exact same problem here, whenever I change the hard drive enclosure OSX wants to initialize again.
    cheers,

    simon
  4. versib01 said:
    Have you found a solution for this?
    I am having the exact same problem here, whenever I change the hard drive enclosure OSX wants to initialize again.
    cheers,

    simon

    Unfortunately no. But after tampering with SATA drivers, etc. I somehow managed to make it work it as long as it is connected to the same SATA controller (for example it works normal if it's connected to SATA #7 port or SATA #8 port, no re-initializing necessary!). I've been using them like this but as soon as I connect them through another connection (like a USB 3.0 socket, etc.) everything's gone!

    I do not know if it's designed like that or something's wrong with my PC but that's the way it works. Internet didn't helped much I'm afraid...

    I'm not familiar with MAC system/drivers but if there'a way to update or manually force to re-install them, maybe it'll fix it, otherwise you'll probably need another enclosure so you wouldn't have to remove that disk!
  5. Fromass, I never saw your initial post, but did you ever try enabling the hot swap setting in your bios -- most boards have it for each SATA channel and disabled by default? Also, I use a little app that just sits in the system tray called HotSwap! from HERE to eject SATA HDDs and between the two it seems to have cured all my large disk issues.

    Also, if you swap drives on the SATA connector a lot, you might consider getting an ICY DOCK MB971SP-B, inexpensive and very convenient.
  6. Hi,

    I just ran into the same problem. However, while reading, I remembered one remark from my Lenovo laptop: Password!!!!
    It said that if I put a password for booting from the HD, The HD can't be used without entering, and also you won't be able it on other computers .....
    So, did you configure a password for booting the machine? That may be the cause. It'd mean that this is actually secure and fine .....

    Chau,

    Update:
    YES!!! That worked. I removed the password on the original computer ( "password not set"), and now it just works!!
    Ready to back-up .....

    Hope it works for you too.

    Cheers,

    Pascal
Ask a new question

Read More

Hard Drives Storage