Sign in with
Sign up | Sign in
Your question
Solved

WD HDD not showing up in Bios?

Last response: in Storage
Share
November 19, 2012 8:03:40 PM

Specs:
Gigabtye GA-890GPA-UD3H
Ram: 2x2GB DDR3 Corsair xms3 1333mz
PSU: Ultra X4 750W ATX
OS: Windows 7


I can't access windows because my My WD Caviar 500GB HDD isn't showing in bios, or well, it's showing up but instead of the slot saying "None" or the name of the drive, the slot is just completely blank so I think the bios might be partially recognizing the drive. dono

I also have a hitachi hdd but it works perfectly fine.

I have tried switching the power cables and putting them in different slots on the psu but to no avail.
The WD is plugged in properly but when the computer starts up the drive doesn't make any noise at all. I have also tried the drive on my laptop via sata-usb adapter and still the drive will not give any indication that it is functioning, no noise, nothing.
Broken? :fou: 

More about : hdd showing bios

Best solution

a c 79 G Storage
November 23, 2012 1:00:01 PM

Sounds to me like it's completely failed. It cannot be tested with diagnostic software either unless it can be persuaded to spin up.
Share
May 22, 2013 9:57:38 AM

I had a similar problem with my WD Blue WD10EZEX 1T that I just received. Everything else int he computer seems to work with aplomb but my HDD was really giving me trouble. It would spin up and the access light indicator would light up on the front of my case, but the HDD made a rhythmic read/write noise and was just acting strangely all around. It wouldn't show in BIOS at all, it would show up at he correct capacity and be assigned but Windows 7 would refuse to install to it, or it would show up as a 2TB drive even though it's 1TB and the only drive int he computer at the moment. At least mine made noise! Tried everything you did too; change ports, cables, BIOS settings, everything I could think of. Finally asked Newegg.com for a new one...I think your drive is simply non-functional. Ask for a replacement...
m
0
l
!