Sign in with
Sign up | Sign in
Your question

Sapphire HD5850 TOXIC fan speed designed at 100%

Last response: in Graphics & Displays
Share
July 14, 2010 7:55:00 AM

Hi, I have just installed the Sapphire HD 5850 TOXIC edition. I was surprised that I cannot adjust the fan speed, it is set at 100% running all the time, and pretty loud and obtrusive. I've done all the things I can think to correct this including getting the latest catalyst drivers, updated the bios of the card and the motherboard, removed all old drivers.

I contacted the Sapphire help desk with this problem and got this response from their support staff:

For the fan speed, HD4850Toxic model can not adjust fan speed. It's runing full speed at all time. It's original designed. If you think fan has hardware issue, please contact your reseller for hardware checking too. Thank you.


Can anyone else confirm or deny this, that the fan speed is supposed to run at full blast all the time on the 4840 TOXIC edition?

This seems crazy to me as it is so loud.

TIA
July 14, 2010 9:35:13 AM

I've tried MSI Afterburner and it appears to have zero effect on the fan speed. The fan speed is fixed at 100% on my machine.

Can anyone who has this card confirm or deny this please?
Related resources
July 14, 2010 9:42:17 AM

Okay, I got an answer from Sapphire. They were talking about the 4850 TOXIC, not the 5850 TOXIC. They have confirmed that the fan is supposed to adjust according to temperature. Mine however, does not. Any ideas?
July 14, 2010 10:06:52 AM

Ignoring the sound is not an option - it is LOUD. I'll post a screenshot later. The gpu is running at about 42 degrees. CCC says that the fan is at 20% or so.

the problem is that it does not matter where I set the fan control it always runs at 100%. Note also that it runs at 100% right from the very start of the boot up, it never slows down from that.
July 14, 2010 1:34:49 PM

Thanks for the help. The card has gone back to the supplier. Very disappointed to be going back to my GT8800 Alpha Dog. At least it is quiet though.
!