Sign in with
Sign up | Sign in
Your question

Weird USB port problem

Last response: in Components
Share
November 7, 2010 5:14:22 PM

Hi everyone,
I've got some weird problem with my USB port in my PC.

Whenever I attach devices to the USB port 2.0 (there are 6 in my PC, 4 in front and 2 in rear ), the device like flash disk either became undetected, detected as corrupt, detected as RAW, or detected as empty. Sometimes it detected normally, but when I try accessing the flash disk, my PC became very sluggish slow,then it froze and I had to abruptly remove my flash disk.. It's not flash disk problem, my flash disks worked well in other PC/laptops..

Another device like printer albeit didn't have much trouble like the flash disk, it keep asking to reinstall its driver whenever I plugged it in to the USB port. even though I attached it to the same port, it will ask to reinstall driver again next time I boot up/power up my printer (and now I have much copy of my printer in Devices and Printers)

But when I plugged the flash disk and the printer to the port USB 3.0 (there are two in rear), they worked like a charm, even actually they aren't 3.0 USB devices!

I have tried every USB 2.0 port, front and rear, with many devices, none worked well. Tried clear BIOS. Tried flash BIOS. Check USB settting in BIOS. disable USB selective suspend setting in power management. None worked.

oh yeah, there isn't any exclamation error showed up in device manager..should I reinstall the driver? or should I reinstall the Windows? or is this hardware failure?


my PC specs:
intel core i7 950
mobo gigabyte x58a-ud3r rev2.0
ati5830
RAM corsair 2x2gb DDR3
casing sim cool v
PS enlight 650w
OS win7 x64

Any ideas? thx for your help

More about : weird usb port problem

November 8, 2010 12:26:34 AM

Try refreshing the chipset from the mobo manufacturers website, as that will refresh the USB controllers.
m
0
l
November 8, 2010 12:41:51 AM

Also, make sure you have the lates Bios updates installed.
m
0
l
Related resources
November 24, 2010 1:53:58 PM

My usb ports are now working (well not completely, but at least I can use it again). Thx for you help, but neither of your solution worked. For me, the working solution is to uninstall the usb port driver (USB root hub),then restart the PC . It will reinstall the usb port automatically, and now my usb port is working again (but temporary, as I have to repeat the process when the error occurred again).
m
0
l
!