Sign in with
Sign up | Sign in
Your question
Closed

Palit 460 GTX...running slow?

Last response: in Graphics & Displays
Share
July 18, 2010 2:14:16 AM

I just installed my new Palit GTX 460 1GB Sonic yesterday and my framerate in TF2 has gone down the toilet. I upgraded from a GTX 260 and it runs a lot better compared to the 460 now. I upgraded so I could play my higher resolutions better, but now I'm scratching my head here. I have installed the latest nVidia drivers released a few days ago that include 460 support. Could the poor performance be due to the new drivers, or is something else wrong?

Phenom II X4 3.2
4GB OCZ 1600
Palit GTX460
Win7 64
July 18, 2010 2:28:38 AM

Not quite sure what is going on here, but yesterday I installed my new Palit 460GTX 1GB Sonic and started up TF2. To my complete surprise, the game ran like absolute doodoo. My framerate was dipping into the 40s, when it never got below 80 with my GTX260. Maybe it's because the drivers were just released a couple days ago and they still need to work out kinks, but I ain't seeing upgraded performance from a 260 to 460 at all. I have a hunch on a few things, but once again nVidia's control panel is a piece of crap. Where the hell do I disable PhysX? I just got CPU, GPU, or auto. I want off damnit. I haven't messed with nTune yet, so maybe its underclocked or something. Doesn't make much sense but I'll take a look at that too. I'll take suggestions or comments. Thanks.


Phenom II x4 3.2
OCZ 4GB 1600
Palit 460GTX
Win7 64
Score
0
July 18, 2010 2:31:26 AM

Ah sorry, I couldn't find the first post after I hit submit, so I thought it timed out or something.
Score
0
Related resources
July 18, 2010 2:42:33 AM

Yes, I'm using 258.96
Score
0
a c 173 U Graphics card
July 18, 2010 2:53:21 AM

Drivers for newer cards tend to be *** at best on first release, the same happened to the 8800gtx and many others.
Score
0
a b U Graphics card
July 18, 2010 3:04:26 AM

The most effective way to "turn off PhysX" is to uninstall it completely. :) 

But you can often times disable it within the game itself, if it uses PhysX. I'm not a TF2 player, so I'm not sure there. ;)  Considering it uses the old engine from Half Life 2, I'm not thinking PhysX is involved... correct me if I'm wrong.
Score
0
July 18, 2010 3:41:41 AM

I'm just hoping that the drivers blow, and that they'll get better. Because as it stands now, my game runs better with my old card. Granted, I play other games as well, but TF2 seems to stand out to as being under performing.

Source uses Havok physics, I was just wondering how to turn PhysX off completely.
Score
0
a c 189 U Graphics card
July 18, 2010 7:35:51 AM

What about your PSU? brand? model?
Score
0
a b U Graphics card
July 18, 2010 8:21:25 AM

i don't think the psu would be a problem since his 260 would use about the same power wise, see if your card is revving up to it's full clock speeds, your gpu-z and click the record log to text fill, and play TF2 and see if it reaches it's 800mhz
Score
0
a c 173 U Graphics card
July 18, 2010 1:40:04 PM

Get Ntune and one of the top tabs it has the options for physx and one is to enable and disable.
Score
0
July 18, 2010 10:29:36 PM

PSU is a Raidmax 630W. I don't power is an issue since I had no problems with my GTX260 which is about twice the size of the 460.

I ran TF2 for about 20 minutes and took a look at the log and the GPU usage was averaging around 50%. It peaked at 93% once.

I'm downloading Just Cause 2 for a little comparison. I already tried Bad Company 2 out and it seemed a little sluggish as well.
Score
0
July 25, 2010 3:50:42 AM

Interesting development, I tested Bad Company 2 against some 460 review benchmarks from various sites (Tom's, Guru, etc.) and found that my average frame rate is about the same, if not better. At 1920X1080 with their specified settings my average FPS was in the mid 40s, with the review benchmarks right around 39-40. I guess TF2 just doesn't run well with this configuration. Bummer, since I play TF2 more now.
Score
0
a c 272 U Graphics card
August 26, 2010 2:55:10 PM

This topic has been closed by Mousemonkey
Score
0
!