Sign in with
Sign up | Sign in
Your question
Closed

Turning Hyper-Threading ON!

Tags:
Last response: in CPUs
Share
November 8, 2010 11:16:11 PM

So how do I turn it on, that is the question? ;) 
The rag is:

Intel Core i7-720QM 1.6GHz (2.8GHz Turbo Mode, 6MB L2 Cache)
Radeon HD5730 1GB DDR3
4096MB DDR3 1066MHz
500GB SATA 5400rpm
17.3" HD+ LED BrightView (1600 x 900)

I think I turned it off somehow (very low CPU score in benchmarking) and I don't know how to turn it on again! I checked the BIOS, there is nothing there!!
November 8, 2010 11:40:10 PM

How do you think you turned it off? AFAIK you can't turn hyperthreading off from within the OS, you need to do it in the BIOS.

Also, mobile processors are much slower than their desktop counterparts. Are you sure you are comparing your benchmark to a reasonable analogue?
Score
0

Best solution

a c 190 à CPUs
November 8, 2010 11:43:24 PM

The control to turn hyper threading on and off has to be in the BIOS. You can use CPU-Z to confirm whether it is on or off.
Share
Related resources
a b à CPUs
November 8, 2010 11:49:12 PM

Or you can use ALL CPU meter sidebar app. It will show up as another core and how much is being used at any given time.
Score
0
November 9, 2010 8:58:47 AM

Best answer selected by Gregorius.
Score
0
November 9, 2010 9:08:49 AM

hunter315 said:
The control to turn hyper threading on and off has to be in the BIOS. You can use CPU-Z to confirm whether it is on or off.


I've checked with CPU-Z, it say's "Cores 1 - Threads 1" :pfff: 


subasteve580
, in 3dmark06 I am getting score 1340, and it should be about 2900 for my CPU!

I recently flashed my BIOS to a newer version, which fix the fan problem, a from then on I probably have this problem... :fou: 
There is nothing in BIOS which can turn HT on of off, what to do now?
There is even newer version of BIOS for my laptop out (Asus N71JQ), maybe to flash the BIOS again...?

Score
0
November 9, 2010 9:42:33 AM

Quote:
I wonder why people ask question after selecting best answer.Downgrade to previous bios.


Because it was the best answer I got, but it didn't resolve my problem! ;) 
I see now that my thread is marked as SOLVED, but it isn't. I am new here so I didn't know that selecting best answer will do that to my thread, and probably a lot of other new members have the same problem! ;) 

Anyhow, how do I downgrade? I flashed via EasyFlash from BIOS, does it remember previous version?
Score
0
a b à CPUs
November 9, 2010 12:42:43 PM

Gregorius said:
Because it was the best answer I got, but it didn't resolve my problem! ;) 
I see now that my thread is marked as SOLVED, but it isn't. I am new here so I didn't know that selecting best answer will do that to my thread, and probably a lot of other new members have the same problem! ;) 

Anyhow, how do I downgrade? I flashed via EasyFlash from BIOS, does it remember previous version?


You shouldn't mark best answer till your problem isnt solved-
Just ask again and wait for members to reply
As Dipankar said, download latest running -
Score
0
a c 190 à CPUs
November 10, 2010 12:42:46 AM

1 core 1 thread definitely isnt right, open up MS config and make sure it isnt set to only use one core, that would restrict you to using a single thread which would definitely limit your performance.
Score
0
November 10, 2010 10:29:59 AM

I resolved my problem! And the problem was that I followed this WIndows7 Optimization Guide which said to run msconfig->boot tab->Advanced options and to set number 2 there under the Number of processors, and the windows was suppose to boot faster!
But when I saw that this didn't reduce the boot time, I just set the number of processors to number 1! :)  And I reduced the number of my cores, not the boot time! :D 

I just disabled this option "Number of processors" and now my system sees my CPU as it should, as quad core CPU, 8 threads!
So everything is ok now, thanks everybody for trying to help...
Score
0
a b à CPUs
November 10, 2010 12:36:52 PM

This topic has been closed by Mousemonkey
Score
0
!