New Build Troubleshooting - Please Help

Hi Guys,

This was my second build ever, my first rig was built about two years ago. I put everything together, ran the wires and plugged everything in. In my mobo I made sure to connect both 8pin power connectors and the 24 pin power connector - I also plugged in both 4 pin connectors as I am running 2xHD5970's.

When I turn on the PSU, the mobo lights come on properly

The problem is. When I press the power button, nothing happens at all. I am new to building computers so I figured you might be able to help as I worked on this for 6 hours last night and even broke it all down and put it back together again, and still the same problem.

Please Help! Thanks in advance!


I have posted specs of this rig below if that would help as well:

Antec Twelve Hundred Black Steel ATX Full Tower Computer Case

ASUS Rampage III Extreme LGA 1366 Intel X58 SATA 6Gb/s USB 3.0 ATX Intel Motherboard

SAPPHIRE 100280SR Radeon HD 5970 (Hemlock) 2GB 512 (256 x 2)-bit GDDR5 PCI Express 2.1 x16 HDCP Ready CrossFireX Support .... X2


CORSAIR HX Series CMPSU-1000HX 1000W ATX12V 2.2 / EPS12V 2.91 SLI Ready CrossFire Ready 80 PLUS Certified Modular Active ...

Intel Core i7-980X Extreme Edition Gulftown 3.33GHz LGA 1366 130W Six-Core Desktop Processor BX80613I7980X

G.SKILL Trident 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 2000 (PC3 16000) Desktop Memory Model F3-16000CL9D-4GBTD

Western Digital Caviar Blue WD6400AAKS 640GB 7200 RPM SATA 3.0Gb/s 3.5" Internal Hard Drive -Bare Drive

ASUS DRW-24B1ST/BLK/B/AS Black SATA 24X DVD Burner

Microsoft Windows 7 Professional 64-bit 1-Pack for System Builders - OEM
1 answer Last reply
More about build troubleshooting help
  1. I would recommend reading through and completing each step in this thread below (some you have already done). It is one of the better troubleshooting guides I've seen around.

    PERFORM THESE STEPS before posting about boot/no video problems!
Ask a new question

Read More

New Build Systems