Sign in with
Sign up | Sign in
Your question

Asus motherboard nic missing

Last response: in Motherboards
Share
July 5, 2011 6:05:08 PM

Hi I have a Zoostorm desktop comoputer with an ASUS P5KPL-AM IN/GB Motherboard.
This board has the Realtek NIC adapter intefral on the board.

This computer is running Windows 7 Ultimate O/S

Since day one there has been a tendency for the adapter to drop out with driver trouble which when disabled re-enabled Driver refreshed etc., all fixed and is OK - until Windows does an update which chucks it out again.

Recently a security update has left the system without a Network Adapter of any kind! that is that there is no Network adapter showing up in Device Settings in Control Panel the system doesn't have a network adapter and I don't know how to get it to ressurect itself.

I have taken it through system restore three times right back past the date and the adapter is still not there.
The other feature of this which is really annoying is that the system blue screens when left for an hour or so.

I have stopped the auto restart to bring up the error and all we get is an IRQ conflict not less or equal to etc., fiddling with the IRQ's doesn't seem to be desirable or even reliable as means of maintaining the interupts in Win 7

Any advice on how to solve this would be much appreciated. The ASUS site says that a windows upgrade can affect the drivers of this Motherboard. Why oh why do we keep having to put up with MS screwing perfectly good kit up. This computer is exactly a year old and therefore no warranty now. I am connecting through the internet via a 300mbps Wifi Dongle which is reliable. Also other computers on the network which this doesn't see etc.;,!
Look forward to your help
a b V Motherboard
July 5, 2011 10:09:52 PM

The IRQL not less or equal BSOD is nothing to do with IRQs - it's kernel speak for "someone tried to do something they are not allowed to do when running under a raised IRQL". It's basically a generic kernel error, indicating that you have a buggy driver in the system.

Pragmatically, I think you have a buggy Realtek NIC / driver. If it were my system I would disable the NIC on the motherboard and go buy a decent Ethernet board - I like Intel boards, but Marvell ones work just as well. A PCI or PCIe Ethernet board is cheap, simple, and should get rid of the problems permanently.
July 6, 2011 3:49:04 AM

could be a driver issue or it's disabled under BIOS...try deleting the driver and re-installing a new one
!