Piriform Speccy shows my RAM clock moving between 200MHz and 400MHz. Why is this. I thought there would be one clock speed. My RAM is Type DDR2
Size 2048 MBytes
Manufacturer Kingston
Max Bandwidth PC2-6400 (400 MHz)
3 answers Last reply Best Answer
More about jedec
  1. Best answer
    You likely have your BIOS DRAM settings on auto, which means that for power saving means, the mobo will flucutate the RAM bus speed. If you want it to stay at a constant 400, you should manually configure the BIOS.
  2. Thank you. That helps.
  3. Best answer selected by standbear.
Ask a new question

Read More

Elitegroup RAM Motherboards