Sign in with
Sign up | Sign in
Your question

[Solved] SanDisk Extreme firmware upgrade cant find drive

Last response: in Storage
Share
November 27, 2012 11:01:32 PM

I have a SanDisk Extreme 240GB SSD. I have installed windows and everything is working fine so far. However I am trying to update the firmware to the latest version. I have tried using the SSD toolkit to create a flash USB boot drive and manually burning the .iso to a disk.

In both cases, when I boot from either the flash drive or disk, I get to the Firmware Updater but there are no devices for me to select for update. I can only select "exit".

The drive is visible in my BIOS, I can select it for the boot priority. Trying to update to firmware R211.

I talked to customer support, but the guy seemed lost the entire time, and eventually told me to just RMA it, but I don't want to be without a drive for 4 weeks and have the chance of it happening again if it was something on my end.

MOBO: Asus P7P55D-E Pro, drive is connected to SATA3 port.

Any help would be GREATLY appreciated, thanks.
November 27, 2012 11:35:37 PM

Ok, I found the solution, too bad SanDisk technical support could find out. I had to plug the SSD into a normal SATA port, not the SATA3 port. This allowed me to upgrade the firmware. I then switched it back to a SATA3 port and it seems to be running fine now. Sorry about making the post, but I figure I'll leave it in case someone else runs into this issue.
m
0
l
!