Sign in with
Sign up | Sign in
Your question
Solved

5970 will spin up to 100% when playing games..

Last response: in Graphics & Displays
Share
July 20, 2010 8:34:25 PM

Hi all,

I recently downloaded MSI Afterburner for my XFX 5970 Black Edition.

In order to get access to the manual fan speed control settings, i had to flash the BIOS of the card to the latest one provided by XFX, i flashed the BIOS exactly to how XFX's guide said.

Initially the manual fan speed control worked fine, but recently for some reason regardless of Afterburner running or not, the graphics card fan will spin up to what seems like 100% (GPU-Z reads 3100 rpm, however this is only stuck at 30% in the percentage readout no matter what speed it goes at, also regardless of program).

Checking the GPU temps nothing seems out of the ordinary, when playing Bad Company 2 (1080, everything max except HBAO) it sticks at around 60-65 degrees C (not surprising on 100%) but it worries me as i don't really want the fan giving it all it can all the time during gameplay sessions incase it dies or something. It also sounds like a small wind tunnel in the office.

Any help will be much appreciated, config is in the sig, thanks.
July 20, 2010 9:20:53 PM

Just a quick update.

Uninstalling MSI Afterburner and clearing the registry of anything it put in there doesn't seem to cure the problem.

I have tried 4 games so far, MW2, BC2, EVE Online and Never Winter Nights 2.

MW2 and BC2 make the card spin up almost straight away, even before the title screen.

EVE Online doesn't make the card spin up at all when in game, however there is no gradual rise in fan speed as the card temps build up (worrying).

Never Winter Nights 2 is the same as EVE Online except when i accidentally pressed the windows key (to the right of control), it minimised the game and brought up the start menu. When this happened the card span up to full speed which is most curious.

My next resort is to completely uninstall the drivers and reinstall them.

Oh and one last thing, the card spins at max until i restart and shut down, i cant seem to find any other way to manually turn it down. (Even when fan speed control was enabled in Afterburner it was only to define the curve of fan speed in the settings box, not to directly control the fan speed % on the main bit as this was still greyed out for some reason).
July 21, 2010 4:35:57 AM

Go back to the original BIOS for the graphics card and see if that helps.
Related resources
July 21, 2010 4:36:38 AM

And next time, just control the fan speed from inside CCC. It works just fine for me.
July 21, 2010 4:44:48 AM

Hey there,

Flashing BIOS shouldn't be done unless manufacturer recommends to do so to fix an issue.

IMO, a 5970 works best using Cat 10.3 or 10.4 drivers.

I used Cat 10.6 and it was unstable as. I had to use driver sweeper (for the first time) to remove them.

Go back and try and create a fan profile.

Good luck.
July 21, 2010 9:46:45 AM

Hey all, thanks for the replies.

Just to let you all know, the issue was fixed.

I uninstalled and reinstalled ATI CCC and display drivers. Something new appeared in the ATI Overdrive called 'enable fan speed control' that was already checked and set to 50% (which must have been what my card was spinning to whenever a game was launched).

Anyway, i set it to computer controlled and it has not played up since :) .

Hunuok, XFX said that this BIOS update was necessary if you wanted to enable fan speed control which wasn't enabled in the original BIOS, so in a sense it wasn't an issue.

Also, how do you create a fan profile? Is this done in CCC?

Best solution

July 21, 2010 10:34:53 AM
Share

Hey there,
Quote:
XFX said that this BIOS update was necessary if you wanted to enable fan speed control which wasn't enabled in the original BIOS


OK.

To create a fan profile:

CCC>graphics>ATI overdrive>click gold padlock key to unlock (if not already done)>click enable manual fan control>set to 50% (or whatever setting)>apply

options (top right corner)>profiles>profiles manager :

1. enter/select profile name
2. click activation tab. choose activation shortcut (ex ALT+C)
3. save

Every time you boot, open CCC and hit shortcut (ex Alt+C). Then fan profile should be activated.

Good luck.
July 21, 2010 11:18:01 AM

Best answer selected by Griffolion.
July 21, 2010 11:19:01 AM

Thanks Hunuok. :) 
July 21, 2010 3:05:57 PM

No problem.
!