Sign in with
Sign up | Sign in
Your question
Solved

SSD in IDE Mode

Last response: in Storage
Share
November 28, 2012 9:10:19 PM

I just purchased an Intel 330 Series 240 GB ssd and I've been trying to get it to work in AHCI mode. I could only get Windows 7 to install to the drive when I set SATA to IDE mode; the Windows 7 installer said it could not be installed to the drive when I had AHCI enabled.

At first, I unplugged my other two hard drives and tried installing Windows 7 via usb drive and it said it couldn't be installed to the drive. I changed the drive to another port and same error. I tried booting into Ubuntu from a live cd and formatting the ssd to NTFS then trying to install Windows 7 again but that didn't work. I also tried plugging my other hard drive with Windows 7 already installed, booting to the old drive, then installing Windows 7 to the ssd from there, but same error.

After I switched to IDE mode, Windows 7 installed normally. I tried doing the registry hack to switch to AHCI then restarting and switching to AHCI in the bios. After Windows loaded, the 'found new hardware' wizard installed the AHCI driver and prompted me to reboot, then when I restarted, Windows wouldn't boot from the drive. In AHCI mode, the ssd shows up both in the bios and on the following AHCI start screen.

I'm currently back in IDE mode. I checked and trim is enabled and my drive speeds seem good (for SATA II, my motherboard doesn't have SATA3), so I'm wondering if I should stick with IDE or attempt to get AHCI mode working.

Motherboard: Asrock A785GXH128M

The BIOS and the SSD are both updated to the latest firmwares.

CrystalDiskMark Benchmark: http://i.imgur.com/idJoN.png

More about : ssd ide mode

a b $ Windows 7
a c 323 G Storage
November 28, 2012 9:40:44 PM

Your read and write speeds are okay for a SATA II connection. You would not notice a real world difference with AHCI, but benchmarks would improve as they would with SATA III.

I don't know how motivated you are to mess with this, but since you can't get AHCI mode working you can use RAID sata mode and then not build a RAID array, just use the solo SSD as AHCI is a subset of RAID you would get the AHCI performance. Of course, that assumes that you would be able to install in RAID sata mode.
m
0
l
November 28, 2012 9:55:51 PM

I just tried switching SATA to RAID mode (the bios has IDE/AHCI/RAID) but Windows BSOD'd just before the desktop, so I switched it back to IDE. I assume that means I'd have to do a reinstall to use RAID mode. I'd rather stick with IDE than mess with RAID, since I have 3 drives that I'd like to keep separate and I've never used RAID.

For the AHCI issue, is it a compatibility issue with the motherboard or a defective drive? I assume it's a compatibility issue because Intel's SSD Toolbox says the drive is fine.
m
0
l
Related resources

Best solution

a b $ Windows 7
a c 323 G Storage
November 28, 2012 10:04:26 PM

No, you can't just switch it in the bios -- you either need to reinstall, or change the registry key to the RAID driver before you restart and change the bios mode. If you want to try that I can give you a step by step.

It sounds like an incompatibility with your somewhat older motherboard, so RAID mode may well not work either.

I would probably just leave it alone -- you wouldn't likely notice any difference anyway other than benchmarks.
Share
November 28, 2012 10:27:40 PM

I'll just leave it alone then. I'm not really going to get any extra speed out of the drive if I'm stuck on SATA II.

Thanks for the help.
m
0
l
November 28, 2012 10:27:54 PM

Best answer selected by ryan392.
m
0
l
a b G Storage
November 28, 2012 10:40:06 PM

Here are a couple ideas that haven't mentioned yet.

1. The switch between IDE and ACHI is difficult because windows chooses which drivers to install the first time you install windows. At the same time it disables the others. If you want to switch I would not try to do the registry hack but I would download microsoft's "fix-it" for making the switch because it not only makes the registry changes but it installs the correct drivers as well.

2. You can look and see if there is a bios update for your mobo. It might help fix the incompatibility issues.
m
0
l
November 29, 2012 12:10:47 AM

1. I just tried that and I'm running into the same problem. After I ran the fix-it, I restarted and switched to AHCI in the bios. Windows loaded fine that time, then after it finished installing the drivers I restarted and it wouldn't boot. It just does not want to boot in AHCI mode.

2. I already updated the bios to the latest version. Didn't help at all.
m
0
l
!