Sign in with
Sign up | Sign in
Your question

My HD is not letting me enter bios, Please Help.

Last response: in Storage
Share
November 29, 2012 11:22:24 AM

Hello, I need some help. I recently upgraded my system but my hard drive is not letting me enter the bios and it wont make me do anything once I plug it the computer just hang in the welcome screen of my motherboard, I get ASUS in the middle of my screen and at the bottom it asks if I want to enter bios setup via DEL or F2 for advanced to use UEFI I try to press either nothing, my keyboard Num lk led is on like its on hang or something, I turn off my pc unplug the hard and everything is back to normal and I can enter bios and check all my plugged stuff, my DVDROM, RAM, my flash memory stick.

ASUS P8B75-V
Kingstone 4GB 2x2 1600 hyperx
i3 3220 Ivy bridge
DVD LiteON 24x
CoolerMaster 600W
WD Cavier green 1TB

Please help me I am so depressed, I wanted to go on and enjoy the new gear but seems joy is not on my side these days.

More about : letting enter bios

a c 75 G Storage
November 29, 2012 11:37:22 AM

what did you upgrade?
November 29, 2012 12:11:32 PM

rgd1101 said:
what did you upgrade?

These are the new parts:
ASUS P8B75-V
Kingstone 4GB 2x2 1600 hyperx
i3 3220 Ivy bridge

and my VGA is EVGA GTS450 1GB SC I forgot to add it the first time.

I tried to plug the hard on all the SATA ports, one port worked once and I manged to enter the bios but the hard is not showing in the SATA config, not detected and just once I tried again and nothing. I also tried to plug my hard drive in another machine it worked just fine, appeared on the mb and I formatted the system partition and no problems and I also noticed that the +12V is not constant it various sometime reads 12.000v and then back to 11.9... in my first use it was 12.128.

Note: I have been using this hard drive for almost 2 years now with no trouble, its the only drive in my system.
December 3, 2012 12:44:06 PM

It seems that my hard drive is busted, I bought a new one and everything is working fine. I lost all my data, so I asked a friend to lend me his hard drive to restore some of my lost data but his hard drive wasn't detected on my motherboard but it was not damaged like mine, its just not detected, am I doing something wrong here!!? why old hard drive are not detected on the mother board?

Note: My friend's hard drive is WD 500 GB 7200 rpm 16 mega buffer and I guess its been 3 or 4 years on the model of the hard drive beacuse at that time there where no colors to specify models like blue, black, green or red.
!