Sign in with
Sign up | Sign in
Your question
Solved

USB 3.0 Expresscard and HDD Issue

Last response: in Storage
Share
November 29, 2012 6:39:22 PM

Hi,

Lately, I have been having some strange issues with USB 3.0 expresscards and a USB 3.0 external hard drive. The card in question is an AKE 3 port Expresscard 54. It uses the Fresco Logic FL1100 chipset. Upon first installation, all worked fine. After a few hours or so, the card acts up. When I plug in my Western Digital My Passport 1TB USB 3.0 hard drive, the hard drive lights up and spins up, but does not show up in Windows Explorer. When looking in device manager, the Expresscard shows a Code 38 warning, stating that the driver is still in memory and to fix this by rebooting. Sometimes rebooting my laptop fixes this, sometimes it does the exact same thing after a reboot. And sometimes it will give the code 38 error after being on for some time (half an hour to 3 hours or more).

I have tried a few things to fix this issue, namely reinstalling the driver and updating the driver. It will work fine for one night or so, then the next day it will act up again. I just want this thing to work right all the time, and I'm not sure what steps I'm missing to make that happen (or if the card itself is just bad).

There is another USB 3.0 Expresscard I have tried and had bad luck with. It's a no name card but has "BC398" on the outside. This is a 2 port card, but it only seems to transfer files at around 15 MB/sec (about half of what I get with USB 2.0). This card uses an ASMedia chipset. Other people with this card, from what I have read, have said similar things.

The laptop in question is a Lenovo Thinkpad X200 running Windows 7 Ultimate 64 bit. I made sure the drivers were 64 bit compatible when I downloaded them. Any ideas? Could it be possible that my Expresscard slot has issues? Thanks for reading.

More about : usb expresscard hdd issue

November 30, 2012 7:31:00 PM

It did it again today. This time, a reboot did not fix it. Same code 38 issue. I had to go into device manager and uninstall the card, then reboot, let Windows reinstall the drivers, and it worked again. Is there any way around this? I suppose I don't absolutely need USB 3.0 speeds all the time, but that's the whole purpose of me buying the card.

Also, I just got a Coolmax USB 3.0 enclosure for an SSD, and it did the same thing with that device. I'm fairly certain it's an issue with either the card, the drivers, or possibly my card slot.
m
0
l

Best solution

July 5, 2013 10:21:21 PM

I eventually found an answer for the issue. I didn't install the Western Digital SES driver. After that, things worked much better.
Share
!