Sign in with
Sign up | Sign in
Your question

Computer won't start with ram in it.

Last response: in Motherboards
Share
July 9, 2011 6:58:03 PM

Hi I have an issue that's been perplexing me for a couple days now. I have made a custom build it's:

Asus sabertooth x58
I7 960
6 x 2GB Corsair Dominator GT Triple Channel 12GB PC15000
PNY GeForce GTX 460

It's not my first build so I'm not a novice but I would call my self an expert. The other day I bought the corsair dominator ram as an upgrade for my computer and after installing it my system ram fine for hours that night. The next day I tried turning on my computer and it powered up but wouldn't boot. My monitor wouldn't receive any signal from my computer and the red ram led light was on on my motherboard. I took out the ram reset it and tried starting it up again but this time it flickered on for a split second and then off, my cold cathodes blinked on and my fans started turning in that split second. While trying to troubleshoot I took out everything out of my system and tried running it and put one peice in back at a time. The computer would start up again but no signal again. After it started I turned it off and I put 1 stick of ram in and nothing, again boots up for a second then dies. I tried 1 and 2 stick in every combination and same issue. One strange thing I noticed is I have a surge protector that cuts power to everything plugged in when the computers power supply switch is off and it makes a loud click noise. Well when I tried booting my computer and it turned on for a second then powered off my surge Protecter would make the loud click and cut power to everything plugged in as if my computers power supply was flipped off in the back. So I thought it was the power supply but I tested another power supply from my old system that worked fine and same issue ram = no start, no ram = start. So sadly I think I shorted the ram slots some how. I was wondering is there anything else I could try. I tried reseating everytging, I unplugged and replugged everything in. I hit the bios reset button on my mobo still same issue. If any one has any info or help greatly appreciated. I'm just worried my mobo ram slots are some how shot. Thanks in advance.

More about : computer start ram

July 10, 2011 1:55:40 AM

Were you wearing your anti-static wrist strap when you installed the ram? Also did you touch the gold pins on the bottom of the ram stick at all?
m
0
l
!