Sign in with
Sign up | Sign in
Your question
Solved

Samsung 840 Pro Series SSD not fast enough...

Tags:
  • SSD
  • Samsung
  • Storage
  • Product
Last response: in Storage
Share
November 30, 2012 12:08:46 PM

Okay, so I recently bought a new ssd from newegg and thought it would be super fast seeing as it's a pretty good brand and all. The advertised speeds on the box/site are 530 read and 390 write whereas I get around 267 read and 240 write. Why is this? I did a clean install of windows 7 onto the ssd with AHCI mode being enabled before I even started the OS installation just like a tutorial instructed me to do...so did I do something wrong or are my slowed speeds a result of the fact that it says my ssd is only running in SATA 3 GB/S?

More about : samsung 840 pro series ssd fast

November 30, 2012 12:15:19 PM

what is your motherboard make and model? even if you have SATA III 6.0 Gb/S controllers, you have to be sure to install it on the right ports. You may have put it on a SATA II 3 Gb/S port, or your motherboard may not have any SATA III ports at all.
m
0
l
November 30, 2012 12:20:36 PM

Mobo: AsRock Z68 Pro3 Gen3. And how do I know which ports are the right ones? sorry for the dumb question, I'm just kind of new to this stuff and I know my mobo has sata 6gb/s ports since this link to newegg http://www.newegg.com/Product/Product.aspx?Item=N82E168... shows so. So I know I CAN connect to sata 6gb/s but would being connected to sata 3gb/s hinder my ssd's speed at all?
m
0
l
Related resources
November 30, 2012 12:27:16 PM

According to your manual, the SATA III ports are gray and labeled SATA3_0 and SATA_1. They're closest to your power connector. The SATA II ports are black. Yes, connecting to the SATA II ports will limit you to half the SSD's capabilities, thus the 250ish metrics you're getting.
m
0
l
November 30, 2012 12:32:44 PM

Ohh, okay thank you so much! I knew something was wrong with those speeds. I'll reconnect it and see how it goes
m
0
l
a b G Storage
November 30, 2012 12:36:16 PM

BTW, advertised speeds are always inflated.
m
0
l
November 30, 2012 12:48:18 PM

Make sure you're using updated firmware and over provision a bit to help with TRIM (if you tend to store a lot of stuff on your SSD).

Both of these also affect performance.
m
0
l
November 30, 2012 1:13:59 PM

i have the same drive. there weren't any firmware updates from what was shipped. and this SSD mostly meets its advertised specs. it's a beast for sure. just hope it's got the reliability of the 830.
m
0
l
November 30, 2012 1:36:04 PM

just plugged it into the sata III port and I got a bsod, why might this of happened?
m
0
l

Best solution

a b G Storage
November 30, 2012 1:42:47 PM

wesman15 said:
just plugged it into the sata III port and I got a bsod, why might this of happened?


Those ports uses a different AHCI driver. You need to reinstall the AHCI driver, or use a trick like this:

http://forum.corsair.com/forums/showthread.php?t=94426

So switch it to the SATA 2 port (slower port), boot into windows, switch the registry (see the link, or use the script) to use the generic driver, then plug the drive into the SATA 3 port (faster port) and boot windows.

Here is the Micro$haft instructions (assuming the drive is bootable, so plug it back to the other port first):

"To resolve this issue yourself, enable the AHCI driver in the registry before you change the SATA mode of the boot drive. To do this, follow these steps:

Exit all Windows-based programs.
Click Start, type regedit in the Start Search box, and then press ENTER.
If you receive the User Account Control dialog box, click Continue.
Locate and then click one of the following registry subkeys:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV
In the pane on the right side, right-click Start in the Name column, and then click Modify.
In the Value data box, type 0, and then click OK.
On the File menu, click Exit to close Registry Editor.
"
Then plug it into the faster SATA port.
Share
November 30, 2012 2:00:11 PM

I plugged the ssd back into the sata ii port and I'm still getting the bsod. The error message screen/blue screen is also going away so fast that I don't have a chance to read what it's saying so I cant tell you all why the bsod is popping up and all. Is there any way from the bios to get it to boot like in a safe mode atleast so I can fix this registry problem and then plug it back into the sata iii port?
m
0
l
November 30, 2012 2:23:19 PM

nvm I got my pc to boot...now I'll go through the steps you mentioned Maxx power and post my results once I'm done. Thanks everyone for all the advice!
m
0
l
November 30, 2012 2:32:34 PM

Maxx_Power said:
Those ports uses a different AHCI driver. You need to reinstall the AHCI driver, or use a trick like this:

http://forum.corsair.com/forums/showthread.php?t=94426

So switch it to the SATA 2 port (slower port), boot into windows, switch the registry (see the link, or use the script) to use the generic driver, then plug the drive into the SATA 3 port (faster port) and boot windows.

Here is the Micro$haft instructions (assuming the drive is bootable, so plug it back to the other port first):

"To resolve this issue yourself, enable the AHCI driver in the registry before you change the SATA mode of the boot drive. To do this, follow these steps:

Exit all Windows-based programs.
Click Start, type regedit in the Start Search box, and then press ENTER.
If you receive the User Account Control dialog box, click Continue.
Locate and then click one of the following registry subkeys:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV
In the pane on the right side, right-click Start in the Name column, and then click Modify.
In the Value data box, type 0, and then click OK.
On the File menu, click Exit to close Registry Editor.
"
Then plug it into the faster SATA port.

I did these steps (specfically modifying the Iastorv file with the 0 in the registry just as u said) and I'm still getting the same blue screen as before. Should I try the automated script now?
m
0
l
a b G Storage
November 30, 2012 5:32:34 PM

wesman15 said:

I did these steps (specfically modifying the Iastorv file with the 0 in the registry just as u said) and I'm still getting the same blue screen as before. Should I try the automated script now?


Okay, try the script first if you want, but in its entirety, try these steps:

1) Set ALL your SATA ports in the BIOS to IDE mode (or compatible mode, the nomenclature varies depending on vendor). Typically you will see RAID, AHCI, IDE. Set this to IDE for ALL ports you have on the board, so, port 1, 2, 3, 4, 5, 6, etc.

2) Try booting the SSD, it SHOULD boot into windows without BSOD on any SATA port, since they are emulating IDE mode.

3) Run the automated script, or do the manual registry modification.

4) Go back into the BIOS, set ALL SATA ports back to AHCI mode.

5) Make sure the SSD is plugged into the SATA 3 (6gbps) port.

6) Boot windows, once you get in, you SHOULD reinstall INTEL storage/chipset drivers.

See if these steps work for you, this should do it if the BSODs are caused by SATA mode change or so.

IF NOT:

Try doing a reinstall/repair on the windows installation by booting with the Windows DVD, and selecting reinstall on top of your existing installation (not side-by-side), a literal re-write of the windows files. Do this while you are in AHCI mode and with the SSD plugged into the SATA 3 (6gbps) port. Windows should fix it self after the installation.
m
0
l
a b G Storage
November 30, 2012 5:34:18 PM

I didn't see it here (maybe I overlooked it), but did you record the error message given by the BSOD ? Post it here (or google it yourself, very quick), and we can see if the BSOD is really related to the SATA drivers.

m
0
l
December 1, 2012 1:01:41 AM

Best answer selected by wesman15.
m
0
l
December 1, 2012 1:01:53 AM

sorry for not responding more promptly but I resolved the issue. Used your step combined with a tip from a friend for setting the ssd as boot drive #1 and all. Anyways thanks though for everyone's help and best answer goes to Maxx Power since he helped me the most
m
0
l
a b G Storage
December 1, 2012 12:30:57 PM

wesman15 said:
sorry for not responding more promptly but I resolved the issue. Used your step combined with a tip from a friend for setting the ssd as boot drive #1 and all. Anyways thanks though for everyone's help and best answer goes to Maxx Power since he helped me the most


Great to hear. Cheers!
m
0
l
!