Sign in with
Sign up | Sign in
Your question

Square smoke in Left 4 Dead 2

Last response: in Graphics & Displays
Share
July 22, 2010 3:46:34 PM

My new ATI 5770 is working great for everything so far except that it is rendering smoke as gray squares in Left 4 Dead 2. Any idea what's going on? Is this fixable? Does this happen to anyone else?

I'm using this Powercolor 5770 in Windows 7.

More about : square smoke left dead

July 22, 2010 3:56:56 PM

Make sure you have the latest VGA drivers installed.
Also try turning on the V-sync and see if it helps
July 22, 2010 4:08:02 PM

Maziar said:
Make sure you have the latest VGA drivers installed.
Also try turning on the V-sync and see if it helps


I have the latest ATI drivers installed, which I should have mentioned in my first post, but I forgot. Is that what you mean by VGA drivers? (http://en.wikipedia.org/wiki/Video_Graphics_Array)

I'll try turning on V-sync when I get home.
Related resources
a b $ Windows 7
July 22, 2010 4:10:20 PM

It could be:

1. You need to update your video card drivers.
2. You have a LCD monitor that uses a TN panel which is having issues displaying the subtleties of smoke.

Example for #2:

My Asus VK246H has a TN panel monitor and during the scene when the Joker blows up the hospital black smoke fills the sky, but the smoke was very pixelated. My more expensive monitors (all IPS) had no such issues.
July 22, 2010 4:48:35 PM

valzi said:
I have the latest ATI drivers installed, which I should have mentioned in my first post, but I forgot. Is that what you mean by VGA drivers? (http://en.wikipedia.org/wiki/Video_Graphics_Array)

I'll try turning on V-sync when I get home.

Yes i meant the latest ATI drivers.
a b $ Windows 7
July 22, 2010 4:58:30 PM

Check the transparency setting in game or the CCC - a squre smoke block would indicate that the game is not processing the transparency properly so the parts that are supposed to be see through are not showing up correctly so try changing the type of transparency you are using.
a b $ Windows 7
July 22, 2010 5:10:53 PM

Unless you have mutiple monitors i.e.eyefinity i suggest you use CC version 10.4.
10.5 and 10.6 have caused nothing but stability issues with my 5850.
July 22, 2010 6:56:33 PM

Alright, I'll try both JDFan's and Davcon's solutions tonight.
July 22, 2010 8:00:08 PM

Don't forget the V-sync.
July 23, 2010 9:35:54 PM

Yes, that too. I didn't get to test any of the three solutions yet. I plan to do so tonight.
July 24, 2010 6:34:08 AM

Okay, I tried all three settings (none, double-buffered, and triple-buffered) for V-sync with no change.
I switched to ATI's 10.4 driver with no change.
Left 4 Dead 2 doesn't have any transparency settings and I don't see any in CCC either.

Also, there is now a FPS display in the top-right corner of any 3D game now. Why is that there? It happened when I changed drivers.

Is there a chance that changing Catalyst AI from standard to advanced would help?

Also, my BIOS is several versions behind. Because this is a new build and I haven't updated it yet, I plan to do so tomorrow. Maybe that will have an effect.

Maybe I should reinstall the game.
July 24, 2010 8:00:37 AM

I think you have installed Fraps,and that's why you see your FPS on top-right corner.
Setting Catalyst AI from standard to advanced shouldn't change anything, but try it.
If none worked,do a clean install of the latest driver(10.6),here is how
,download DRIVER SWEEPER(from guru3d.com,then
1_Go to control panel and uninstall the driver from there
2_Reboot and go to safemode and open driver sweeper and click on "ATI",then select clean.
3_Re-boot normally and Install the new driver
a b $ Windows 7
July 24, 2010 2:26:15 PM

I just looked at my Left for Dead 2 settings and as you know V-sync and transparency are not user enabled settings.
It may be just a matter of adjusting some of your settings from high to medium.
Also you'll notice the bottom video setting that says recommended settings.
A 5770 is not going to play that game as smooth as my 5850 on max settings.

Use recommended settings and back off to medium on one or two experiment a bit.
July 24, 2010 4:51:29 PM

I tried setting all graphic settings to low. The smoke is still squares.
July 24, 2010 4:56:55 PM

Maziar said:
I think you have installed Fraps,and that's why you see your FPS on top-right corner.
Setting Catalyst AI from standard to advanced shouldn't change anything, but try it.
If none worked,do a clean install of the latest driver(10.6),here is how
,download DRIVER SWEEPER(from guru3d.com,then
1_Go to control panel and uninstall the driver from there
2_Reboot and go to safemode and open driver sweeper and click on "ATI",then select clean.
3_Re-boot normally and Install the new driver


I don't have Fraps.

And yes, that's the method I used when I changed from 10.6 to 10.4.
a b $ Windows 7
July 24, 2010 5:03:01 PM

IS there an .ini file for left for dead 2 ( I don't have the game) -- what I think may be the problem is the same thing I run into with Oblivion on my 5770 --- THe autodetect of the game autodetects the ATI 5770 as an OLD NVIDIA FX57XX Card which is a card that had problems with the implementation of the shaders (OB defaults to Ultra Low settings due to this and turns off many of the shaders - So I have to then change the setting to Ultra High in the launcher to correct it and also adjust the ini file to allow the use of 3.0 shader model) -- It may be that Left 4 Dead is doing the same and setting the game up for the old FX5700 Nvidia card - so see if there is an ini file where you can change the settings the game uses.
July 24, 2010 5:38:00 PM

Searching for an .ini in my folder as well as searching Google for a way to tweak settings yields nothing yet.
July 24, 2010 5:43:14 PM

Here's a screenshot showing my smoke and the annoying FPS indicator.

July 24, 2010 5:52:22 PM

I figured out that the FPS indicator disappears when I close ATI Tray Tools. Apparently it's in there somewhere. :pfff:  So now we're back to just square smoke. :D 
a b $ Windows 7
July 25, 2010 12:18:38 AM

I've heard of Ati tray tools but have never used it.Maybe it's the source of your issues.
Another idea is to uninstall the game and re-install it.
Which is pretty easy now considering Steam client does it automatically.
July 25, 2010 6:28:07 AM

I've had the square smoke since before I installed any 3rd party graphics programs (including ATI Tray Tools), so it's only the source of the new FPS thing.

I don't have a fast internet connection, so I'll have to hold off on reinstalling for a couple of days, but I'll definitely try that.

Thanks for the help everyone! I'll let you know how things work out in a few days.
!