Poor SSD performance, tried everything.

Hello,

Getting under 200 MB/s read and under 80 MB/s write, info:

Running Adata S510 120 GB SSD on Win 7, Lenovo T420 laptop, here is what I've verified/tried:

Latest SSD firmware
Latest Lenovo chipset drivers
Updated/Switched to Intel RST drivers (no change)
Verified TRIM enabled
Disabled caching
Verified AHCI is enabled in BIOS and in Windows
Verified its SATA III
Changed power profile to max performance
Disabled Defrag schedule
ATTO has similar results

I have done every major step that I can find, it seems everyone with this poor of benchmarks are running in SATA 1 or SATA 2, or have their TRIM disabled or don't have AHCI enabled. Not me.

Any ideas?

Seq read 172 MB/s, Write 76.MB/s
4k 12.77 MB/s Write 47.8 MB/s
4K-64Thrd 82.53 Write 61.07
Acc. Time .312 ms write .375 ms
Score 113/116 287 total.
3 answers Last reply
More about poor performance everything
  1. How did you verify that the laptop has SATA 3 (6Gb/s) ports?

    Lenovo's datasheet indicates that it has SATA 2 (3Gb/s) ports:
    http://www.lenovo.com/shop/americas/content/pdf/system_data/t420_tech_specs.pdf
  2. I'm using the internal slot/port, which is supposed to be 6 GB/s, plus I installed the Intel RST application which reports the bus bandwidth at 6 GB/s
  3. Update 2: I am running Ubuntu Live 12.10, fastest sequential read is 172 MB/s, which is very close to Win 7 benchmarks.

    Wondering if I got a bum drive?
Ask a new question

Read More

SSD Performance SATA Storage