Sign in with
Sign up | Sign in
Your question

ATX power-off problem

Last response: in Systems
Share
August 26, 2010 10:55:44 PM

Hi guys! Before posting I searched all over the web but no use. I hope to get an answer from here.
I have an ancient system with a P-III (700mhz), 810 chipset and 512mB ram. A few days ago it was working fine.
Then, one day I decided to thoroughly clean it. So I opened the system, disassembled it completely and cleaned all the parts with a mild and soft brush and then used a blower to blow all the dust away.
After that I assembled it as it was previously. Then I powered it on and everything seemed fine but one thing I noticed was Power-off button was not working. Instead it would freeze the system in its current state, whether its a post screen or under windows. The power-off button only works in the force shutdown mode, i.e. when the power-off button is pressed for over 5 sec it force-shutdowns the system.
The power-on and reset button are working absolutely fine. Moreover, when I turn-off the system using Windows' shut-down option, it won't turn-off. Instead it would hang at the screen where it says, 'Windows is shutting down' and takes forever. To turn the system off I have to manually pull the power cable out from the PSU.
I have already rechecked all the LED and power leads that goes into the motherboard and also tried swapping the reset button with the power button but still no success, it still freezes. That means the switches and power leads are fine and it narrows down the problem to either mobo or PSU. Its really baffling me!

Guys, I know its a very old system and needs to be thrown out of the window but I really want to use it just for surfing and listening songs as I have my analog 5.1 speakers attached to it.
Plz help! Your replies are appreciated.

More about : atx power problem

a b B Homebuilt system
August 26, 2010 11:22:10 PM

What happens if you HIBERNATE?

If hibernation (probably SHIFT->STANDBY) works that would seem to isolate everything but a faulty ON/OFF switch.

For troubeshooting it really helps to be able to check parts against something else. For example, if you can try that PSU in another computer which is compatible then you can prove the PSU.

Basically you need to isolate the components somehow.
m
0
l
August 27, 2010 10:21:41 AM

Thanks photonboy for that photon-speed reply.
When I hibernate, the hibernation process stucks at 100% progress bar and freezes. Then I have to do the force-shutdown. The surprising thing is I am able to successfully wake-up from the hibernation when I turn the PC back ON.
Moreover when I turn-off the PC through Windows (plus using force-shutdown to literally turn it off) and then boot back, Windows isn't able to recognize an unexpected shutdown and doesn't starts the 'chkdsk' process (I am using FAT32).
It means logically the shutdown is working through windows as it should but on a hardware level it stucks where the hardware should turn itself off or more precisely soft-off (as in case of ATX).
Does this problem may relate to any jumper setting also?
m
0
l
Related resources
August 27, 2010 12:27:11 PM

Run some test on your hard drive. Use utilities from that manufacturer's site.
m
0
l
August 27, 2010 1:42:20 PM

@punnar.
No, the hard disk is working fine as I have tried an another HD but the same problem persists.
m
0
l
August 27, 2010 6:21:37 PM

Thanks guys for your precious replies. I have resolved the problem. That problem was related to an IRQ conflict. During the post screen I noticed that the 'SMBus Controller' and the 'ACPI Controller' had the same IRQ No., i.e. 9. I had a soundcard and a WLAN card in the 1st and 2nd PCI Slot respectively. Then I remember that I had removed my network controller (LAN Card) from the 3rd PCI Slot during the reassembling, hence the change in IRQ numbers. So what I did was inserting the LAN card back into 3rd PCI slot. This changed the IRQ numbers b/w SMBus controller and the ACPI Controller, they were no longer the same. So this solved my problem of IRQ conflict and now my power-off button is working fine as usual. ACPI is related to power, right! that's why it wasn't working.
BUT now I want to ask an another question. What if I don't want to use my LAN card. I haven't found an another method to power-off my PC without using that LAN Card in the 3rd slot. In other words, how can I change the IRQ numbers?
m
0
l
August 30, 2010 8:20:02 AM

Try uninstalling the drivers for the device before removing it from your system the OS won't try to look for it.
m
0
l
!