Sign in with
Sign up | Sign in
Your question

Single SSD(OS) + three 1TB HDD(raid5 storage)

Last response: in Storage
Share
December 1, 2012 5:55:52 PM

I'm in a bit of a pickle and I need some brains to figure this out.

Here's my current build: :heink: 
MB: ASUS crosshair iv formula
three 1TB HDD in raid5 with windows 7 installed as well as all my data and is working fine.

The goal: :ange: 
I bought a Samsung 840 250GB SSD ($140) and plan to put my OS (windows 7 fresh install) and programs on this drive.
I plan to keep my old set of three 1TB drives in Raid5 or Raid0 for storage.

The problem: :??: 
When my SATA controller is set to RAID in the BIOS, I cannot see my SSD from the windows 7 install even after installing the correct RAID driver. I have loaded the raid drivers and if I hook up my current RAID5 array and load the windows 7 install CD I can see the current RAID5 array, but still not the SSD. I have tried making the SSD "RAID READY" from the RAID setup menu and this does not help.

The good: :wahoo: 
My BIOS sees the SSD just fine and I can easily install windows 7 to it when the SATA controller is set to AHCI.

What I've tried: :o 
SSD firmware is up-to-date
I installed windows 7 to the SDD (all other drives disconnected) while SATA is set to AHCI. I then set SATA ports 1-4 to RAID mode and SATA ports 5-6 to IDE as AHCI are not available when ports 1-4 are in RAID mode.
I plugged the SSD into port 5 (IDE) and windows still booted just fine. Windows now detected the RAID controller and I was able to install the RAID drivers manually.
I shutdown, plugged the SSD into port 4 (RAID MODE) and tried to boot up windows 7. BSOD as the driver didn't load (I'm pretty sure). If I change port 4 back to AHCI mode, then windows boots again.

I've read about the registry hack to switch between AHCI and RAID so I checked the registry and both msahci start=0 and ahcix64s start=0 also.

The ugly: :fou: 
I cannot get windows 7 to boot up on the SSD with the SATA controller set to RAID no matter what I try. I can't install windows 7 to the SSD if the SATA controller is set to RAID as it doesn't see the SSD during install. (I'm using an install disk with windows 7 service pack 1 integrated).
I don't want to leave the SSD in port 5 or 6 with IDE mode enabled as I won't be able to use TRIM and other fuctions of the SSD.


Any and all assistance would be greatly appreciated. I've pulled out almost all of my hair on this one. :cry: 
January 26, 2013 12:42:38 PM

Hey I found this,

http://superuser.com/questions/430241/is-it-possible-to...

Says if you put two SSDs alone in RAID format it should work. However if you try to mix and match between SSD and HDD in RAID Format it will run into an issue with the TRIM protocols or something like that. Basically something they needed to run RAID on HDD was called TRIM. When they made SSDs they didn't need TRIM so it's not their. RAID current drivers have adapted to run on SSDs without TRIM but apparently you can't use TRIM and not use TRIM. I don't know what TRIM actually does.
!