Sign in with
Sign up | Sign in
Your question

Mouse not operating at DPI it claims to be on

Last response: in Components
Share
November 16, 2010 11:32:00 AM

Hello,
I got an A4-Tech X7 gaming mouse (XL-750BK). When I first got it, I was using an old PS/2 mouse and forgot that I had USB mice disabled in the BIOS. I plugged in the USB mouse and installed the new mouse's software off its disc. It actually worked despite the BIOS setting.

Then I ran into big problems. I was playing with the settings, and increased the USB polling/report rate from 125Hz (default) to 500Hz and then 1000Hz. At 500Hz it was nice and smooth, but when I put it on 1000Hz it spazzed out and started moving erratically, 5 pixels at a time (total loss of precision). The left and right clicks also just stopped functioning. After restarting and still having the problem, I plugged in the PS/2 mouse again and put the setting down to 125Hz again. It was still broken. I restarted, unplugging the PS/2. Still messed up. I then unplugged the new mouse and plugged it in a new USB port and tada! The mouse calmed down again but it did not move very fast even when on 3600dpi.

At this point I remembered the BIOS setting and enabled USB mice. After this I could put the mouse on 1000Hz with no problem, but still have this problem that the mouse is not moving at its full speed.

Current settings:
USB mouse enabled in BIOS
USB keybaord disabled in BIOS (didn't have any effect)
USB polling rate is set to 500Hz
Windows mouse pointer speed (sensitivity) is set to 6 (a.k.a. default setting)
Windows enhanced precision is disabled.
Running Windows 7 x64
Windows device manager reports that the mouse is "HID-compliant mouse"

I did a test to determine the actual dpi of my mouse at its various settings, the results are below:



I've been just using the mouse like this for about a month, on 3600dpi. But it really annoys me, I want to be able to get all my DPIs!!

Please, any help or suggestions would be appreciated. Let me know if you need additional information.
November 16, 2010 1:42:33 PM

Try plugging the mouse in some other computer and check what DPI it runs at when you set it to 3600. If it does not, chances are it a defective piece.
m
0
l
November 16, 2010 2:32:12 PM

Good suggestion. I tried it on my friend's Mac. It was super snappy on his computer, so it would seem the mouse is fine.

I'll try and get hold of someone's high DPI mouse to test on my machine to see what happens.
m
0
l
November 16, 2010 2:41:27 PM

I'm not allowed to edit my post, so:

Tried a friend's Razer "precision pro 1.6". It moved across my screen in only 2.2cm (0.866141732 in), giving ~1660 dpi. This corresponds to its advertised 1600 dpi rating on the box. It feels faster too.
m
0
l
!