Sign in with
Sign up | Sign in
Your question
Closed

Mercury Playback Engine (CUDA) and PhysX with ATI Radeon and GTS 250

Last response: in Graphics & Displays
Share
July 23, 2010 9:41:43 PM

Hello
I have the Radeon 5830 and the GTS 250

However, whenever I want to use Adobe Premiere CS5, I can't use the Mercury Engine.

As a matter of fact, the program won't even run

If I disable the extended monitors, then, and only then, it works

However, the Mercury Playback Engine works with SOFTWARE mode (meaning it's using the CPU only), and not with HARDWARDE mode (meaning it's using Nvidia's GPU/CUDA power)

Any suggestions?
July 23, 2010 9:51:45 PM

rafarataneneces said:
Hello
I have the Radeon 5830 and the GTS 250

However, whenever I want to use Adobe Premiere CS5, I can't use the Mercury Engine.

As a matter of fact, the program won't even run

If I disable the extended monitors, then, and only then, it works

However, the Mercury Playback Engine works with SOFTWARE mode (meaning it's using the CPU only), and not with HARDWARDE mode (meaning it's using Nvidia's GPU/CUDA power)

Any suggestions?


Ok, I finally got it working

I need 2 HDMI cables

1) from my Nvidia card to my Samsung 32"
2) from my ATI card to my Samsung 32"

Therefore, if I want to
1) use Adobe Premiere CS5 with the Mercury Playback Engine
I will have to use the Extended display, with both cables coming out of the Nvidia card

2) Play games
I will have to change the input of my TV and change it to the HDMI cable coming out of my ATI card

In both scenarios, I HAVE to use Extended Display

So, if I want to use Adobe Premiere CS5, switch to HDMI1
If I want to play games, switch to HDMI2

Now I FINALLY have

ATI + Nvidia (PhysX + Cuda)

Batman Arkham Asylum working great with PhysX
Adobe Premiere CS5 working great with Mercury Playback Engine

Now, if I ever need to sell/replace my graphic card, I can still use the GTS 250 to play games and use Adobe Premiere CS5

I think I might go with

GTS 250 + GTX 460

or stick with
GTS 250 + Radeon 5830

Personally I like ATI more because the cards are more efficient, they use less power, plus they produce less heat

With this setup, I could even have

ATI Eyefinity + Nvidia PhysX/CUDA

Damn, I am SO HAPPY I was finally able to mix + match Nvidia + ATI :) 
Score
0
September 17, 2010 4:17:19 PM

This post finally gave me the answer I needed (I thank everyone who ever goes back to post fixes they discover - they are truly kings among men) so lemme toss in my two bits.

The two connection fix is, based on what GPU-Z is telling me, the result of CUDA being disabled if the NVIDIA card is not the primary renderer. My setup has a Powercolor PCs+ Radeon 5770 alongside an MSI Cyclone OC GTS 450, and GPU-Z's little checkboxes at the bottom show PhysX enabled for both cards regardless of which one is the renderer (thanks to the Hybrid PhysX hack) but the CUDA checkbox is only enabled when I am running my display from the 450.

Another niggle is that the 450's adaptive power mode only works if the card is the primary renderer as well, but that might be a result of the drivers (who releases beta drivers as the only drivers available for a new card at launch? I ask you...).

Anyways, based on what I'm seeing sofar, while the Mercury Playback Engine benefits significantly from CUDA's GPU acceleration, it's not taxing the GPU AT ALL.

My specs:

Foxconn A79A-S 790FX mobo
4GB OCZ Platinum 1066 DDR2
AMD X3 440 with the 4th core unlocked
the abovementioned video cards
Windows 7 x64

My test transcode was a 1080p 59.94fps Lagarith-encoded file, and I was transcoding it to a Blu-Ray compliant 720p 59.94fps H.264 file, maximum render depth and maximum render quality both enabled.

In Software mode, the encoder took about 35 mins/minute of footage.

With GPU acceration enabled, the transcode time for the exact same file was reduced to 18 minutes/minute of footage. (!)

The funny thing was, the GPU load (according to GPU-Z) peaked at only 10%, which means either a) the GPU load measurement GPU-Z uses shows the overall GPU load, of which the load on the CUDA (shader) cores is only a fraction of the whole, b) the Mercury engine has a lot of headroom left to leverage, or c) something is hooped in my config. For what it's worth, my Fluidmark PhysX scores are off the charts brutal, (but that might be just an effect of the Hybrid PhysX hack) so c) might very well be correct.

In contrast, using the AVIVO encoder on the same file resulted in a 7 minute/minute of footage transcode to the same format, though only 29.97 fps, and since you can't control the settings for the transcode past a Quality slider, this solution is pretty much unusable. Though, it may back up the stats companies like CyberLink trot out where they show similar improvements to transcode times regardless of whether CUDA or ATI Stream are used.

Anyways, the last note I wanted to add was this: for me, the way I work the cabling to enable CUDA is to have the DVI cable connected to the 450 at boot and any time I'm working in Premiere, then if I'm gaming I disconnect the cable and connect it to the 5770 (my monitor only has one digital input). The system rejigs to use the Radeon card automatically and all is right with the world. Hope this helps somebody else like the OP helped me.
Score
0
a c 273 U Graphics card
September 17, 2010 4:46:35 PM

This topic has been closed by Mousemonkey
Score
0
!