Radeon 3850 attempting to update 10.6 on 32 bit XP service pack 3

Okay d/l'd both just the display driver program and the catalyst. Ran both and neither would update the actual driver file it would just update my catalyst. Uninstalled old vid driver, catalyst, catalyst install manager and started it all over again still no dice!
Went under device manager and tried to just browse to the actual folder where the drivers are at and update manually and it won't work either. After I installed everything it still shows the old 2008 driver installed 6.14.0010.6788.

It's an older AGP system that I'm using while TDY that runs well, but I can't get it to update the driver any thoughts would be amazing at this point. ATM all it is shows installed is vga.d11 (2001) which I'm assuming is a default driver for XP.
4 answers Last reply
More about radeon 3850 attempting update service pack
  1. are you sure you are downloading the correct version of catalyst?

    certainly sounds like the wrong driver is being selected.
  2. I beleive you need to use the Hotfix driver for AGP and not the main driver listed on the page. I am not 100% sure so read this first and see it it covers you issue if so down load it and give it a go http://support.amd.com/us/kbarticles/Pages/CatalystAGPHotfix.aspx

    Mactronix
  3. Hey thanks guys I appreciate it, the hotfix driver for AGP 10.6 helped me out!
  4. Glad I could help.

    Mactronix
Ask a new question

Read More

Radeon Catalyst Graphics