Sign in with
Sign up | Sign in
Your question

Windows wireless zero configuration error 1067

Last response: in Wireless Networking
Share
July 12, 2010 12:33:50 AM

I am using a d-link dwl-g122 to connect to the internet. It says it is connected, but I still can't run internet explorer or play online games. I suspect that this is due to the wireless zero configuration service, which isn't activated. Every time I try to start it, I get error 1067, "the process was terminated unexpectedly".
Any info or solutions would be greatly appreciated, as I have been trying to get this to work for about 7 months.
Thank you!
Anonymous
a b F Wireless
July 12, 2010 9:12:16 AM

If the D-Link comes with its own utilities these may work better than Windows Zero Config. But within them (or within Windows Networking) you can usually select Zero Config to manage the connection instead.

You may need to re-run Windows Networking Wizard.

Also check TCP/IP Properties.
Start, Connect To, Connection, Properties, Scroll Down TCP/IP and highlight, click Properties and check that Obtain DNS and IP address automatically are enabled.


However, there are so many other potential issues with wireless that I think I would start by connecting the computer to the router with an ethernet cable and first check that you can get on the internet that way.

Then look at the router's user setup screens (see literature which came with router for how) and make sure wireless mode is compatible with the D-Link (wireless g or mixed mode will work) and turn off wireless security. Then try connecting by wireless again.
m
0
l
July 12, 2010 8:58:19 PM

Thank you, you are the first person in quite a few forums to give a serious answer.

I already have the d-link utility installed and running. It used to say that I was connected, but I just checked a few seconds ago and now it says that I am not connected!

The problem was that the d-link utility used say that I was connected, but Internet explorer and other programs still could not connect. I know that it is possible to connect wirelessly with this equipment, I have done it before. But I had a regestry error among other things and had to wipe my computer clean. Now it won't work.
m
0
l
Related resources
Anonymous
a b F Wireless
July 12, 2010 9:57:33 PM

Just re-reading your earlier comments. You do not need to run both Windows Zero Config and the adapter's own utilities -- it's one or the other.

As I said, before getting involved with wireless issues, make sure the computer can connect to the router -- and then to the internet -- when linked by ethernet cable to the router. If it won't work that way, that must be remedied first before messing with wireless.

If wired works, the next step must be to try to connect wirelessly without security -- and preferably with the router and computer in the same room to eliminate range and interference issues.

In fixing computers you have to be boringly systematic, eliminating one potential problem area and then another -- until the likely solution emerges.
m
0
l
July 13, 2010 2:39:43 AM

Ok, I didn't know that you only need one.

I'll try linking it directly to the router like you said. That might take a while because the computer is upstairs and the router is downstairs.
m
0
l
July 13, 2010 6:46:56 AM

Okay, so I've got the computer downstairs, hooked up with an ethernet cable. Now what?
m
0
l
Anonymous
a b F Wireless
July 13, 2010 12:16:21 PM

Have you got the literature which came with the router ? Or download the full manual from DLink.

You need the IP of the router (often 192.168.0.1 or check by using IPCONFIG /ALL in a DOS box from Command Prompt). Put the IP into the address bar of your browser and you should then see a DLink logo and a login box -- the user name is always admin. The password may be left blank or be something like password or admin -- see router literature.

Once in go to Wireless settings and check that SSID is being broadcast not hidden, that wireless is enabled, that wireless mode is g or n or mixed mode (depending on the type of wireless adapter in your computer).

In Wireless Security select no security, for the time being.

If there is an option for something named Access List or similar (admit or refuse by MAC ID) disable it.

Save settings and log out.

Disconnect ethernet and see if you can get back in to the router setup via wireless.
m
0
l
July 13, 2010 6:44:18 PM

I have the computer hooked up with the cable, but I can't access the internet yet. Do I have to do something to confirm my connection? Where would that be?

Sorry if this is a really obvious question, I know nothing of computers.
m
0
l
Anonymous
a b F Wireless
July 13, 2010 9:44:47 PM

Never mind the internet, can you talk to the router's user setup screens ?
m
0
l
July 13, 2010 10:26:45 PM

Sorry, but I have no idea how to go about doing that.

I am so confused right now.
All of this login stuff you're talking about applies to d-link routers, right?
My router is not a d-link product. It is a Verizon Fios router.

I read the manual for my router and discovered something identical to the log-in page you mentioned. I enter "http://192.168.1.1" into the address bar but I still get a "the page cannot be displayed" message because I don't have internet access.

So I need to access the internet to get the internet working? That doesn't seem right to me.
m
0
l
Anonymous
a b F Wireless
July 14, 2010 2:59:10 AM

Sorry, the DLink logo won't appear because the router isn't a DLink, the wireless adapter is (bear in mind that in between answering your posts I am juggling about ten other posts on average)

Everything else I have said should apply to any brand of router. You need to sit down with the literature for your router -- either the quick start leaflet Verizon probably provided or the full manual from the original manufacturer's website.

More than anything else in computing, networking is a professional-level technology thrust upon consumers who are used to nothing more complex than a TV remote or washing machine control panel. In order to avoid paying someone else to fix your problems you'll have to bone-up on the technology. There are few shortcuts.

It would help NOT to use wireless which adds another layer of complexity and unreliability.
m
0
l
July 14, 2010 6:17:44 AM

I understand that you are replying to about a dozen different people, and I am very grateful that you are helping me.

This is what I don't understand. This log-in in page needs internet explorer working to be displayed. But getting internet explorer working is what I have been trying to achieve this whole time.

Also, it seems that this page is for getting the router working. My router is working perfectly. I have two computers currently connected to the internet (hence me talking to you). I don't know what isn't working. I have my d-link airplus utility installed and connecting to my router. But for some reason my computer refuses to use this connection to access the internet.

Also, using a wired connection is out of the question as the computer in question is located on a different floor than the router.

Thank you for your time, I really appreciate it.
m
0
l
Anonymous
a b F Wireless
July 14, 2010 9:09:23 AM

I may be slightly misunderstanding you, but if presently you cannot get Internet Explorer to work via wireless, the answer is either:

a) Try another browser
b) stop trying to access the router's setup screens via wireless because it doesn't presently work. Instead move the computer to the same room as the router and use ethernet cable while trying to fix wireless.
c) Try using another computer to access the router's user interface in order to fix its wireless to work with your computer (checking settings that might exclude your particular computer such as wireless mode, access list and wireless security type/password).


m
0
l
July 14, 2010 9:09:03 PM

B) I currently have the computer hooked up to the router with an ethernet cable. It still isn't working. The router detects that the ethernet cable is plugged into the computer, but the computer detects no signs of being connected. Under network connections in the control panel nothing shows up. I get a message saying

"The Network Connections Folder was unable to retrieve the list of network adapters on your machine. Please make sure that the Network Connections service is enabled and running."

My network connections service is enabled and running.
m
0
l
Anonymous
a b F Wireless
July 15, 2010 11:50:39 AM

The message suggests that your wired ethernet connector driver is not installed. Or that you have no TCP/IP networking protocol installed.

Check Control Panel, System, Hardware, Device Manager to see if your ethernet adapter is present (or is yellow flagged as faulty).

Run Networking Wizard.

m
0
l
July 16, 2010 9:44:43 PM

The device manager states that thRealtk RTL8139 Family PCI Fast Ethernet NIC is "working properly".

If by Networking Wizard you mean Network Setup Wizard, I have tried that thing almost a dozen times. It gives me the same message as the network connections thing in the control panel. I have completed the wizard many times, only to find no changes.
m
0
l
Anonymous
a b F Wireless
July 16, 2010 10:21:49 PM

With router wired to the computer go Start, All Programs, Accessories, Command Prompt and type IPCONFIG /ALL -- when the results appear, next to the word gateway their should be an IP address in the range circa 192.168.0.1 which should be the address of the router. If nothing appears next to gateway press the reset button on the router, wait for it to boot up and lights to settle down. Re run the above and see if the an IP address in the above range appears.

You should then be able to connect.


If not, I'm stumped. I can only suggest you borrow a router or a computer to check whether fault is in your router or your computer.
m
0
l
July 17, 2010 5:31:30 AM

I reset it, and nothing shows up next to default gateway. There is IP Address, though, which is 0.0.0.0. I'm guessing that that's not working either.

I did notice that on the Command Prompt, my D-link shows up. Another thing I think might be of importance is that next to IP Routing Enabled, it says no.

I know that fault is in my computer and that my router is working perfectly. Wireless is working on the router, as I am using a laptop right now.
m
0
l
Anonymous
a b F Wireless
July 17, 2010 8:36:59 AM

The zeros mean there's no IP address being detected. IP Routing is not significant, apparently.


Compare your read out with mine and see what's missing:
Windows IP Configuration



Host Name . . . . . . . . . . . . : DEKKER

Primary Dns Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Unknown

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No



Ethernet adapter Local Area Connection:



Media State . . . . . . . . . . . : Media disconnected

Description . . . . . . . . . . . : Realtek RTL8139 Family PCI Fast Ethernet NIC

Physical Address. . . . . . . . . : (the MAC ID is there but removed by me for security - fihart)




Ethernet adapter Wireless Network Connection 8:



Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : 802.11g Wireless LAN PCI Card

Physical Address. . . . . . . . . : (the MAC ID is there but removed by me for security - fihart)

Dhcp Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

IP Address. . . . . . . . . . . . : 192.168.0.3

Subnet Mask . . . . . . . . . . . : 255.255.255.0

Default Gateway . . . . . . . . . : 192.168.0.1

DHCP Server . . . . . . . . . . . : 192.168.0.1

DNS Servers . . . . . . . . . . . : 192.168.0.1

Lease Obtained. . . . . . . . . . : 17 July 2010 09:21:29

Lease Expires . . . . . . . . . . : 20 July 2010 09:21:29

m
0
l
July 20, 2010 6:31:44 PM

It looks different than yours. I have way less things under "Ethernet adapter Wireless Network Connection 6" than you. Our connections seem to be switched. My wireless says "media disconnected", and your wired says that.

Anyways, here the entire thing.
Windows IP Configuration
Host Name....................................OKCOMPUTER
Primary Dns Suffix.........................
Node Type.....................................Broadcast
Ip Routing Enabled........................No
Wins Proxy Enabled.......................No

Ethernet adapter local area connection 2:
Connection Specific DNS Suffix........
Description......................................Realtek RTL8139 Family PCI Fast Ethernet NIC
Physical Address.............................00-0C-6E-F6-A3-D3
Dhcp Enabled..................................Yes
Autoconfiguration Enabled..............Yes
IP Address.......................................0.0.0.0
Subnet Mask....................................0.0.0.0
Default Gateway..............................
DHCP Server....................................0.0.0.0

Ethernet adapter Wireless Network Connection 6:
Media State......................................Media Disconnected
Description.......................................D-link AirPlus G DWL-G122 Wireless USB Adapter(rev.B) #2
Physical............................................00-11-95-E6-1F-88

You don't need to reply to this anytime soon. I'm going to be gone for 2-3 days. Thank you for your help!
m
0
l
Anonymous
a b F Wireless
July 20, 2010 6:35:04 PM

Add a response when you get back.
m
0
l
July 25, 2010 12:18:01 AM

Hey, I'm back.

So what do you think the problem is? My IP can't be found?
m
0
l
Anonymous
a b F Wireless
July 25, 2010 9:11:44 AM

I slightly suspect the router still, despite the logic of your point that another computer connects to it okay. There are occasionally incompatibilities between different generations of equipment. I know for example there are issues between a couple of brands of 802.11g wireless adapters I have and (so far) one model of 802.11 n router (not yours) set to n+g (mixed mode).

As you probably can't change the router, I would suggest borrowing another router (hopefully a spare) and try connecting your computer to that. If that also proves impossible you must consider buying a new wireless adapter recommended by the supplier of your Verizon router.

First review the points we've discussed and if there's anything that isn't clear, feel free to ask.

m
0
l
July 26, 2010 5:31:57 AM

Yeah, I'm considering just buying a new adapter, since they really aren't that expensive.

But I'm hesitating because I have gotten this D-Link one to work, so maybe a new adapter won't solve the problem.
m
0
l
July 27, 2010 3:41:47 AM

Do you have any adapters to recommend? Any that you know will work?
m
0
l
Anonymous
a b F Wireless
July 27, 2010 9:27:48 AM

Frankly, they're all much the same as they use a small range of chipsets supplied by outside firms. If you want the promise of after sales service go for the known brands -- Netgear, Linksys.
m
0
l
!