Sign in with
Sign up | Sign in
Your question
Closed

5870 Crossfire Screen Tearing Issue

Last response: in Graphics & Displays
Share
July 24, 2010 4:30:56 PM

Im currently getting a flickering issue when crossfire is enabled, no decreased performance the cards seem to run fine apart from this, i have tried all the usual tricks 1 bridge, 2 bridges, dvi over hdmi etc 10.5 drivers and 10.6, different monitor and nothing seems to reslove it, my specs are Mentioned in the sig, if any1 would be able to assist me i would highly appreciate it

Thanks


Its only when i run any game



CPU : Core i7 920@3.6Ghz
Motherboard : EVGA X-58 LE
Memory : G Skill Tri Channel 6GB DDR3 1600MHz
Graphics Card : 2x Sapphire ATi 5870 in CrossfireX
Display : Samsung P2250 Full HD
Cooling : TRUE Black Rev 120
Storage & OS : 1.0TB WD Black | 7 Ultimate x64
Case : Coolermaster HAF 922
PSU : XFX Black Edition 850W
July 24, 2010 5:44:38 PM

What resolution are you running at and have you tried forcing v-sync and triple buffering?
Score
0
July 24, 2010 5:50:01 PM

1920x1080

and yes i did
Score
0
Related resources
July 29, 2010 3:41:05 PM

Here's a Video for the same

updated to 10.7

and tried on 10.4 10.5 10.6 and 10.7 same issue on every set of drivers

Score
0
July 31, 2010 4:02:49 AM

can some one help me

and its screen tearing issue
Score
0
January 3, 2012 4:11:48 AM

I know this is a crazy as hell thread resurrection but maybe some others are running into these kinds of problems still. I was suffering from the exact same issue as you, But ONLY when I was in crossfire, everything was perfect with a single card. I think I only started noticing this with DX9 games (Guild Wars and Halo both did it, Skyrim didn't seem to tear, but the thing that was causing it was still observed while playing) after I installed 12.1 preview drivers.

For me the problem was the way AMD Power savings works by adjusting the GPU/Memory clocks for both video cards. One card would be running at 850mhz/1200mhz While the second one was sitting at 157mhz/300mhz, or between that and 600/900mhz, right in the middle of a gaming session. I'm assuming that really screws with settings like Vsync so thats why even with Vsync enabled it seemed to make no difference on or off.

NOTE: Pretty sure doing this method voids the warranty, just a note

So to keep both cards running at a constant 850/1200mhz I used the method of editing the .xml Profile: (Win7)


C:\Users\YourUsername\AppData\Local\ATI\ACE\

1. Right click Profiles and open it with Notepad ( You may want to Copy/paste the original profile to the Desktop in case you find that this doesn't work for your system )

2. CTRL+F search for: ForceHigh3DClocks

<Feature name="ForceHigh3DClocks">
<Property name="ForceHigh3DClocks" value="Disable">

-Type Enable in place of Disable.
-Repeat this again for the second card: Find next ForceHigh3DClocks, Enable in place of Disable

3. These values depend on what kind of card you have, but if you have a 5870 it should be Identical to mine.

-CTRL+F search again for: OverclockEnabledProperty

These are the settings I used. I referenced the highest values ("Want_2") from CoreClockTarget_1, MemoryClockTarget_1, and CoreVoltageTarget_1 to get the values for Want_0 and Want_1 of the rest. I would leave the MemoryVoltageTarget's at 0.

<Feature name="OverclockEnabled">
<Property name="OverclockEnabledProperty" value="False" />
</Feature>
<Feature name="CoreClockTarget_0">
<Property name="Want_0" value="0" /> ~ Changed to 85000
<Property name="Want_1" value="0" /> ~ Changed to 85000
<Property name="Want_2" value="85000" />
</Feature>
<Feature name="MemoryClockTarget_0">
<Property name="Want_0" value="0" /> ~ Changed to 120000
<Property name="Want_1" value="0" /> ~ Changed to 120000
<Property name="Want_2" value="120000" />
</Feature>
<Feature name="CoreVoltageTarget_0">
<Property name="Want_0" value="0" /> ~ Changed to 1163
<Property name="Want_1" value="0" /> ~ Changed to 1163
<Property name="Want_2" value="0" /> ~ Changed to 1163
</Feature>
<Feature name="MemoryVoltageTarget_0"> Left these at 0
<Property name="Want_0" value="0" />
<Property name="Want_1" value="0" />
<Property name="Want_2" value="0" />
</Feature>
<Feature name="FanSpeedProtocol_0">
<Property name="FanSpeedProtocolProperty" value="RPM" />
</Feature>
<Feature name="FanSpeedAlgorithm_0">
<Property name="FanSpeedAlgorithm" value="Automatic" />
</Feature>
<Feature name="FanSpeedRPMTarget_0">
<Property name="Want" value="0" />
</Feature>
<Feature name="FanSpeedPercentTarget_0">
<Property name="Want" value="0" />
</Feature>
<Feature name="CoreClockTarget_1">
<Property name="Want_0" value="15700" /> ~ Changed to 85000
<Property name="Want_1" value="60000" /> ~ Changed to 85000
<Property name="Want_2" value="85000" /> - Referenced
</Feature>
<Feature name="MemoryClockTarget_1">
<Property name="Want_0" value="30000" /> ~ Changed to 120000
<Property name="Want_1" value="90000" /> ~ Changed to 120000
<Property name="Want_2" value="120000" /> - Referenced
</Feature>
<Feature name="CoreVoltageTarget_1">
<Property name="Want_0" value="950" /> ~ Changed to 1163
<Property name="Want_1" value="1063" /> ~ Changed to 1163
<Property name="Want_2" value="1163" /> ~ Referenced
</Feature>
<Feature name="MemoryVoltageTarget_1"> Also left at 0
<Property name="Want_0" value="0" />
<Property name="Want_1" value="0" />
<Property name="Want_2" value="0" />
</Feature>
<Feature name="FanSpeedProtocol_1">
<Property name="FanSpeedProtocolProperty" value="Percent" />
</Feature>
<Feature name="FanSpeedAlgorithm_1">
<Property name="FanSpeedAlgorithm" value="Automatic" />
</Feature>
<Feature name="FanSpeedRPMTarget_1">
<Property name="Want" value="1246" />
</Feature>
<Feature name="FanSpeedPercentTarget_1">
<Property name="Want" value="50" />

4. Open up Task manager and close CCC.exe and MOM.exe ( Windows might say the programs not working properly, click cancel if it asks to search for a solution) then Save As the Profiles document, Navigate to the ATI folder and save it over the previous one. You might have to have windows display All file types to see the original .xml document.

5. Restart, Open up CCC, Enable AMD Overdrive. If you want to shut off the forced clock settings just disable Overdrive. It'll go back to power saving modes until you turn it on again. Hope this helps!
Score
0
!