Sign in with
Sign up | Sign in
Your question

CD-ROM not recognized in boot-up. Why?

Last response: in Components
Share
November 17, 2010 12:52:01 PM

On my Dell Dimension 4300, I checked the Boot Sequence, and it shows:

1. CD-ROM (not installed)
2. Diskette Drive
3. Hard-Disk Drive C:

All of these have a checkmark next to them, meaning that the BIOS supposedly recognizes them.

But "not installed" is incorrect. I have a CD and a DVD drive, and both are working properly. As well, when I hit CTL-ALT-DEL, the lights on these 2 drives go on.

So what's wrong here? How do I get my machine to boot from the CD drive?

More about : rom recognized boot

November 17, 2010 6:50:06 PM

I assume when you say both are working properly, that means you can read data off of disks from within your OS, correct? Those lights blinking only means they have power, which is still good to know.

Here's something you can try. Restart your computer and press F12. What F12 should bring up is a one-time boot menu (this seems to be standard on Dell computers). From this boot menu, see if the computer will boot from the CD drive (or if it gives you other options like your DVD drive).

Did you try editing the boot-order, what other devices does it let you select from? Did both drives (CD and DVD) come with the computer, or did you add one in later (Dell has so many configurations)? It's possible the computer is confused. Are both drives SATA or are they IDE, and if they're IDE, are they on the same cable? If they are IDE on the same cable, try booting from whichever drive is master (either set by jumper and/or at the end of the cable). If you added-in a drive, remove it (or if both drives are on one cable, remove the slave drive).

You could also try resetting the BIOS (unplug the computer and remove the battery for a minute), then go back in and reset the boot order, see if that fixes anything.

Otherwise, I'm not sure what the problem could be besides something broken in the computer.
m
0
l
November 17, 2010 9:33:15 PM

Thanks for your reply.

F12 was the first thing I thought of. When I press it and the machine goes into that mode, it displays:

F12 Boot Device Menu
1. Normal
2. Diskette Drive
3. Hard-disk Drive C:

So the CD / DVD choice is missing from that menu.

I checked the jumper selection on these 2 drives. The CD drive is the last one on the cable, and the jumper on it is set to SLave. The DVD jumper is set to Cable Select.

As an experiment, I unplugged the signal cable to the DVD and then checked the Boot Sequence entry. It still shows "CD-ROM device (not installed)".

I will do another expt and reset the jumper on it to Master and see what happens. But I am not optimistic.

On the F12 menu, I select choice 2, and then I can hear the machine reading the floppy (created on another XP machine), and then I eventually get that same HAL.DLL message .

Any further ideas?
m
0
l
Related resources
November 17, 2010 9:46:42 PM

Try removing the CD drive from the setup, leave in the DVD drive. Set it as Master. Make sure the data cable and the power cable are properly plugged in the drive and in the mobo. Reboot and see what happens when you do the F12.

If it doesn't work, do the same but with the CD drive instead of DVD drive.
m
0
l
November 17, 2010 11:51:07 PM

If none of the above work try updating your bios to latest version, via dell website.

To be honest though to be one of the settings just set wrong, as House70 said check its all set as master and all connected ok, if not try rotating the connection on both cd and dvd drive with each other.
m
0
l
November 18, 2010 5:04:33 PM

to: House70, Hellwig, and Signor:

I feel very foolish. I should have remembered about the jumper settings! I changed the jumper to make the CD drive MASTER and of course the system recognized it and booted from it!

thanks for your help.
m
0
l
November 18, 2010 5:25:37 PM

you're welcome, glad we could help.
m
0
l
January 18, 2014 10:34:44 PM

So ANSWER IS: Set your CD rom jumpers to master and your hard disk to slave ! problem solved....
m
0
l
!