Sign in with
Sign up | Sign in
Your question

Kingston HyperX 3K 240Gb Firware weird update failure

Last response: in Storage
Share
December 4, 2012 10:27:29 AM

Dear Community,

I have the weirdest issue on my new 240Gb Kingston HyperX SSD.
Factory release is firmware 501 revision and logically wanted to update to current 503 before installing Win 7 64Gb
I used the tool kit from their website and slaved the drive in my current setup; it correctly identified the drive and performed the update with the green "correct" tick mark.
Verified by rescanning the disks and it still reports version 501

I have subsequently tried this after the Win 7 install - with the zipped file extracted to the SSD itself and other local drives.
I have downloaded the app again, 3 times = all in all I have tried about 15 times from different locations, still saying 501
Used an independent tool to verify the drive ans still reports it on 501

Any ideas please as my native read speed is only 300 and writing 240 - this is under par

Running of a ASUS Rampage III Formula Motherboard on Marvel SATA3 6Gb connector with new SATA3 cable.

I am aware that due to a lack of knowledge beforehand I initiated the drive in IDE mode and not AHCI - I will redo the drive if I can get the firmware issue sorted and to be sure I don't have a physical disk issue

Any help and/or guidance will be appreciated

Thank you
Eugene
a b G Storage
December 4, 2012 12:48:54 PM

Please try Intel controller, often the IOs are even better using Intel's 3 Gb/s controller compared to Marvell 6 Gb/s.
December 4, 2012 1:28:12 PM

The Mobo only has onboard 4 x normal SATA2 ports and 2 x 6Gb Marvel ones.
I have seen a lot of complaints on Marvel performance in general, testing on both shows a slightly better speed on intel

One tip I got is to put the port in BIOS on AHCI before doing the firmware update - this might be a solution as to why it doesn't want to upgrade:
Plan of action: format HDD, put port on AHCI, retry the firmware upgrade, then install Win 7 again
!