Sign in with
Sign up | Sign in
Your question

Rampage III Formula- DOA?

Last response: in Motherboards
Share
July 14, 2011 7:26:00 PM

Hey guys,

I have not idea what a DOA should resemble, but I'm wondering if this sounds like one with my new mobo. Please note: all pieces of my system were used in the past year, but I decided to switch from a Gigabyte UD3R to an Asus.

System
NEW MOBO: Asus Rampage III Formula ( http://www.newegg.com/Product/Prod [...] _-text-_-)

CPU: i7-930 (http://www.newegg.com/Product/Product.aspx?Item=N82E168...)

PSU: Corsair TX750v2 (http://www.newegg.com/Product/Product.aspx?Item=N82E168...), HOWEVER, NOW USING A 750 WATT

Graphics Card: PNY Geforce GTX 470 (http://www.newegg.com/Product/Product.aspx?Item=N82E168...)

RAM: Muskin Redline 6 GB-3x2 (http://www.newegg.com/Product/Product.aspx?Item=N82E168...)

Heatsink: Xigmatek Dark Knight


Problems

1. Package with mobo did not seem overly damaged. However, inspecting inside, there appeared to be a decal sticker (that semi hard 'powered by xx' randomly strewn across the the bottom of the mobo (by my front panel options). Randomly as in, crooked, hanging off, style. Nothing else appeared wrong (but I was not paying close attention).

2. I took out my old mobo and followed all the instructions for cleaning the old thermal paste off with ArctiClean, then reapplied. My pins were identical to my old mobo, so I didnt have to change that.

3. I then connected my PSU to my power strip, and switched the PSU on. The system tried to boot up without me pressing the power button on either the case or mobo. I watched as my LEDs and fans all started up, then the CPU fan immediately quit (this happened about 0.5 seconds after I switched it on, and the LED on the heatsink remained on). The CPU fan began to twitch every 2 seconds, almost looking like it wanted to start. I saw no indicator lights on my motherboard. I heard no beep codes (and I had the speaker plugged into the mobo). I noticed that all my fans seem to be much spinning much slower than they had been with my old mobo. I tried using the power off button/reset, both on my mobo and on my case, no change. LEDs remained on, fans spun slow, and the cpu fan twitched.

4. I turned off my PSU, and I began checked my 8 pin and 24 pin connections. It appeared to be power related. Removed 2 sticks of ram. Tried to power up. Same thing. Changed my graphics card slot. Same problem.

5. I decided to check that PSU. Even though it had worked with my old mobo, perhaps it was messed up. I plugged in my 850 w PSY, and same problem occurred.

7. I cleared my CMOS through removing my Mobo's battery for 10 minutes. Tried start up, same problem.

8. I decided I'd reseat my CPU, did that, and same problem.

What strikes me odd is that power seems low (despite changing PSUs), the cpu fan is twitching, and the power button on the mobo and case do nothing.

Is this a damaged Mobo?
July 14, 2011 7:29:14 PM

Edit: Already tried contacting Asus, but there were no reps available.
!