Sign in with
Sign up | Sign in
Your question

SATA not recognized after adding 3rd drive

Tags:
  • Gigabyte
  • SATA
  • Motherboards
Last response: in Motherboards
Share
July 17, 2011 4:59:40 AM

I have 2 older machines which are used for non-critical work - both use Gigabyte GA-MA790GP-DSH4 mobos. I built both of them about 18 months ago and each has been in continuous service ever since with not a single problem. (background - I have built well over 100 systems (for myself and at work) in the last 20 years and have a fairly high degree of tech savvy)

Recently I wanted to add a second 1TB sata drive to one of the machines, and I got an especially good buy on a WD 1TB drive - although it is sata3, not 2. The drive runs fine as a sata2 drive in another machine that only supports sata2 (tested AFTER the problem first happened).

I shut down, put it in one of the two boxes with the GA-MA790GP-GSH4's, and then rebooted. The machine previously had 2 sata2 drives and 2 sata dvd burners in it and had no problems. When I rebooted with the sata3 drive in it, the bios saw NO sata devices - period.

So I removed the sata3 drive and rebooted - the box still did not recognize its sata drives.

I suspeted a bios problem (it had the original F1 bios in it) and so I flashed the bios upgrading it to F6. The upgrade ran fine and the machine came up successfully showing the new bios. However, still no sata drives recognized. I have tried every trick I know and I cannot get it to locate any sata devices. (IDE/PATA works just fine - but that doesn't help.

I removed the drive and rebooted - and still no SATA drives are seen. After testing the sata3 drive in another box. with no problems, I put it into the 2nd machine with the same mobo, and it, too can no longer recognize any sata drives.

It isn't a matter of recognizing what's on the drive(s) - the drives are not seen at all.

Currently I'm stumped. Any suggestions would be greatly appreciated.

More about : sata recognized adding 3rd drive

a b V Motherboard
July 17, 2011 10:33:43 AM

That's crazy. I don't have a rational explanation for it.

Have you tried resetting the CMOS parameters?

Have you tried changing things like the mode of the SATA controller (between IDE / AHCI, for example)?

Have you tried the classic "unplug the SATA cables and reconnect them" trick? It probably won't change anything, but...

Did you try using different SATA cables?

I was wondering if you'd cracked the SATA connectors connection to the motherboard, but that's the sort of improbable accident that wouldn't happen to both motherboards.

Good luck - I fear you are going to need it.
m
0
l
July 17, 2011 5:06:08 PM

I have tried:
A) literally ALL of the possible sata connection options on the mob for each drive (CHS, LBA, LARGE, AUTO) and have tried the drives individually in every one of the SATA controller;
B) 2 different sets of cables known to be working properly (and one new set). This included plugging and unplugging the cables of course;
C) A completely different PS (power supply) in the machine;
D) Verified that all 3 drives - with their cables - work perfectly in another machine;
D) Disabling both IDE & SATA; save and reboot; re-enable SATA; reboot; re-enable IDE (just in case there's a logic problem in the bios); reboot;
E) Upgrading the bios to the last non-beta bios elease (F6). [I also tried that "latest" version, F7i, but went back to 6 as 7 is still the beta release ... just in case.]
F) Finally, I also plugged in an IDE DVD drive (which IS recognized) and tried first a diagnostic cd (couldn't find the drives of course) and at someone's suggestiong, put the win7 distribution disk in. As expected it didn't find any drives either...

I had been wondering whether there could be a bug in the SATA controller firmware which caused it to get "killed" (apparently permanently) when I plugged in the SATA3 drive there. Although it sounds unlikely and rom what I have read that OUGHT to be impossible. (However, "ought to" is always suspect) I'm still wondering... because that would explain the problems I'm seeing.


m
0
l
a b V Motherboard
July 20, 2011 2:23:40 PM

Hi there,

Interesting! Something happened on the MB, either the BIOS, it's settings, the SATA controller, or controller driver.

You updated the BIOS.
Go into the BIOS and make absolutely sure the SATA controller/s are Enabled. If so, Disable, reboot, then Enable,
Lastly, reinstall the chipset drivers to see if that makes any difference.
m
0
l
!