Sign in with
Sign up | Sign in
Your question

AHCI vs IDE for Vertex 4 SSD on Sabertooth X58

Last response: in Storage
Share
December 7, 2012 5:43:37 PM

I originally installed Windows 7 on my Vertex 4 256GB SSD in my Sabertooth X58 motherboard as AHCI (using the Intel controller, not Marvell).

However, playing around with the motherboard, I saw the CMOS? battery was sideways so I popped it in. Of course, this reset my BIOS completely.

Now in the bios see the Storage Controller is IDE instead of AHCI. Trying to set it back to AHCI causes Windows to have a problem and reboot itself right after the loading screen. But if I set the bios to IDE, then it boots into Windows without a problem.

I tried the registry fix then changing to AHCI without any luck.

Do I need to be worried about this? I really don't want to have to reinstall Windows again and it seems IDE vs AHCI is a deep topic - both support TRIM and the NCQ is really for spinning disks... Can I just leave it as IDE?

Thanks for any help.
a c 134 G Storage
December 7, 2012 6:00:58 PM

Do you try this from microsoft http://support.microsoft.com/kb/922976#method1

If you use the new AHCI from intel, there are two more controllers IastorA or IastorF to change.

After changing it , back to BIOS change to AHCI mode and reboot the PC.

And if you are lazy to re-install the win7, it is ok leave it as IDE, but you still better to try to fix it.
m
0
l
a c 95 G Storage
December 7, 2012 6:16:58 PM

You need to be in AHCI mode for TRIM to perform properly.

Try the tweaks mentioned and set to AHCI mode.

Good luck!
m
0
l
Related resources
Can't find your answer ? Ask !
December 7, 2012 7:16:17 PM

Tried all the registry settings - I was screwed because I did a Windows 8 update on top of Windows 7. I spent about 6 hours this morning reading everything I could on this, tried hours of registry key changes.

In the end, did a system restore from a few days ago - was able to set AHCI and boot into Windows.

Good grief. :(  Now to make up for a few days.
m
0
l
December 7, 2012 7:21:47 PM

Lesson be learned.... You accidentally reset CMOS battery and you use AHCI - change it back right away before you do anything! :p 
m
0
l
a c 353 G Storage
December 7, 2012 7:26:35 PM

^ dah, you want him to change back to IDE??
He has got it working with Bios set to AHCI, and as Col Geek stated - Trim is NOT suported in IDE using the pcide controller, even if trim showsenabled in registry.
m
0
l
December 7, 2012 7:36:00 PM

No I was saying, to warn others if they made my mistake - that if you have AHCI set on an Sabertooth X58 motherboard and the BIOS gets reset, realize you need to set it back to AHCI ASAP because you'll screw up windows bad by running it under IDE for days like I did. All the registry edits for Windows 8 didn't work - in the end I had to do a System Restore.
m
0
l
!