Sign in with
Sign up | Sign in
Your question

DDR3 Ram not working at correct speed

Tags:
  • Memory
  • DDR3
  • RAM
Last response: in Memory
Share
July 18, 2011 6:21:00 PM

Hello, I just ran 3Dmark 11 on my computer out of interest, and to my shock found that the memory was only running at 667mhz. Any idea's why or how I fix it please? Can I change it manually in my bios? Because my ram is supposed to run at 1600mhz

Thanks

More about : ddr3 ram working correct speed

a c 347 } Memory
July 18, 2011 6:38:52 PM

If you're looking at CPU-z then you're seeing 'I/O bus clock (MHz)' 667MHz => 1333 'Data rate (MT/s).' Note: there won't be a dramatic increase once set.

Q - what AMD GA-XXXXX- UD3H? http://www.gigabyte.com/search/search.aspx?kw=UD3H
Related resources
a c 347 } Memory
July 18, 2011 7:29:24 PM

The 'Memory' tab is what you need to look at, and if it says DRAM Frequency = 800 MHz then you're running DDR3 1600. Next, the RAM MUST be installed in pairs and it MUST be installed in the SAME color DIMM slots to run as Dual Channel; Blue/Blue OR White/White.

Example 1066 (533 x 2) in Dual Channel:
July 18, 2011 8:04:02 PM

ohh I always thought that were supposed to put them in the opposite colour DIMM slots?
a c 347 } Memory
July 18, 2011 8:25:19 PM

No, if you want Dual Channel use same color; see page 16 of your manual. I always double-check before I post. it's always the same color but sometimes you can use Blue only or White only - in your case it's either but NOT Blue/White :)  Blue/White is killing your Dual Channel.

Your GA-890GPA-UD3H (rev. 3.1) is like this:
July 18, 2011 9:19:39 PM

Will swap them over now mate, thank you very much for your help :) 
a c 347 } Memory
July 18, 2011 10:04:36 PM

Let me know & Good Luck!
July 20, 2011 6:56:15 AM

Get into the BIOS and change your "memory multiplier" until it's running at stock speed.
!