Solved

Used external HDD to boot Linux. Now it's not recognized by Windows

I tried to install Debian 6 to an external hard drive, but it wouldn't boot. I tried to connect it to my Windows PC, but it wouldn't recognize the HDD. I went to the Control Panel and went to devices and printers. There is an icon for removable media. I cannot access it, and it Windows has no information on it. How can I get Windows to recognize the external hard drive?
Thanks
6 answers Last reply Best Answer
More about used external boot linux recognized windows
  1. In order for Windows to recognise (ie mount) a Linux file system, you need something like ...

    http://sourceforge.net/projects/ext2read/
    http://www.fs-driver.org/
    http://sourceforge.net/projects/ext2fsd/files/
  2. Best answer
    Linux by default uses different file system format.
    Therefore Linux formatted partitions are not readable in Windows natively
    You can format the drive if you don't have any important data and continue to use it as usual or use the software/drivers mentioned in above post...

    Btw, did to try changing the boot order in the bios after you connected the ext HDD?
    Also next time you try to install an OS-linux or any other on external hard disk, disconnect any internal drives and then install the OS. This way the boot-loader will be installed on the ext HDD by default. So you will be able to boot from the HDD even if you connect it to another PC.
  3. _kaos_ said:
    Linux by default uses different file system format.
    Therefore Linux formatted partitions are not readable in Windows natively
    You can format the drive if you don't have any important data and continue to use it as usual or use the software/drivers mentioned in above post...

    Btw, did to try changing the boot order in the bios after you connected the ext HDD?
    Also next time you try to install an OS-linux or any other on external hard disk, disconnect any internal drives and then install the OS. This way the boot-loader will be installed on the ext HDD by default. So you will be able to boot from the HDD even if you connect it to another PC.


    Yeah I set the BIOS to boot USB-HDD. I never disconnected the internal hard drive, though. Ill try that.
  4. swallowtail said:
    Yeah I set the BIOS to boot USB-HDD. I never disconnected the internal hard drive, though. Ill try that.

    ah! I forgot to mention that you also need to enable "boot from usb" option or something similar-can't remember clearly...

    There is also a bios hot-key that lets you directly select which drive/media you want to boot through. So you don't have to change the boot order every time.
    It's different for different bios. Try finding which works for your bios.
  5. Best answer selected by swallowtail.
  6. All I needed to do was remove the internal hard drive. It's funny: It was something as simple as removing the internal hard drive so that the GRUB wouldn't be installed to the it., yet I have spent the past 3 days trying to figure it out. Thanks!
Ask a new question

Read More

Hard Drives Boot External Hard Drive Storage