How to configre DDR2 800 to run at full speed ( 800Mhz )

Hi,
I,m new here and my first question is regarding RAM configration.

I have an Asrock NF6GVSTA, 2GB DDR2 800 Kingston kit and an AMD X2 5200+. According to CPU Z my memory runs at 400mhz right now ( 200mhz ram speed ) and I can't figure out what changes should I make in BIOS to set the RAM to 800Mhz as now its running half speed.
I tried to manually set the RAS, CAS etc values as shown in CPU Z Jedec for 400Mhz but nothing changed.

I noticed that if I enable AM2Boost in BIOS the memory ideed runs at 400Mhz but I loose AMD Cool&Quiet function and others as well.
9 answers Last reply
More about configre ddr2 full speed 800mhz
  1. You need to set the RAM speed in the BIOS.
  2. It is set at DDR800 !
  3. I tried enabling AM2Boost function in BIOS, that disabled Cool and Quiet function and made the RAM run at 333 Mhz in CPU-z.

    I still don't get why my memory doesn't want to run at 800mhz !

    Here are some screenshots from Cpu-z


    http://postimage.org/gallery/68u8p5f2g/
  4. O_o that can't be right. Your memory divider is reporting CPU/5, which would be 542 DDR 1084!! For some reason it seems to be giving you the base (or Bus) speed instead. Otherewise you would have to have a memory divider of 13.5, which I assure you is not the case (only whole numbers 13 or 14 no 13.5).
  5. I'm going to say just disable Cool n Quiet. You don't have to enable that "AM2Boost"
  6. I've disabled the Cool and Quiet function, now it says CPU\13 in the memory tab but the RAM still runs at 200Mhz !
  7. If the divider is set at 13 then your memory should be running at 207, not 200 so it's wrong. I'm going to have to say it looks like you have a BIOS problem due to having an outdated BIOS. Looking the ASRock support page there was a few BIOS updates since the initial release and one of those updates was for memory issues

    http://www.asrock.com/mb/download.asp?Model=ALiveNF6G-VSTA&o=BIOS

    Download and update to the latest BIOS for your board. See if that doesn't fix it.
  8. I have the latest BIOS ! v2.30

    You gave me a link to A-LiveNF6G-VSTA wich is another mainboard, mine is AM2NG6G-VSTA, but, I just did rewrite the latest BIOS version just to make sure, nothing changed unfortunately. Still multiplier is 13.5 or 13, memory is seen in BIOS as DDR800, it is set at 400Mhz but still runs at 200, have no ideea what is going on ! This is becoming a mistery
  9. -_- I'm at a loss then. I'd email ASRock and ask them WTF!!! Yeah 2.3 is the is the latest BIOS on that board, and looking at the CPU support it's designed only for AM2 CPUs.
Ask a new question

Read More

Memory DDR2 RAM